aboutsummaryrefslogtreecommitdiff
path: root/comms/wspr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/wspr/Makefile')
-rw-r--r--comms/wspr/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 64903a4539e3..ae29efc44956 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -13,9 +13,9 @@ COMMENT= Weak signal for HF ham radio communication package
LICENSE= GPLv3
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYTHON_LIBDIR}/tkinter:x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL:graphics/py-pillow \
- ${PYTHON_SITELIBDIR}/scipy:science/py-scipy
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
LIB_DEPENDS= libhamlib.so:comms/hamlib \
libfftw3f.so:math/fftw3-float \
libsamplerate.so:audio/libsamplerate \
@@ -63,9 +63,4 @@ do-fetch:
.endif
.endif
-.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
- ${PYTHON_VER} != ${PYTHON_DEFAULT}
-IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
-.endif
-
.include <bsd.port.post.mk>