aboutsummaryrefslogtreecommitdiff
path: root/comms/xastir/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/xastir/Makefile')
-rw-r--r--comms/xastir/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 7535b2aee4ae..93ec2daa3e1d 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -1,12 +1,12 @@
-# Created by: Carl Makin <carl@stagecraft.cx>
-
PORTNAME= xastir
DISTVERSIONPREFIX= Release-
-DISTVERSION= 2.1.8
+DISTVERSION= 2.2.0
+PORTREVISION= 4
CATEGORIES= comms hamradio
MAINTAINER= carl@stagecraft.cx
COMMENT= X Amateur Station Tracking and Information Reporting
+WWW= http://www.xastir.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -23,13 +23,16 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libwebp.so:graphics/webp \
libwebpmux.so:graphics/webp \
libwmflite.so:graphics/libwmf \
- libpcre.so:devel/pcre
+ libpcre2-8.so:devel/pcre2 \
+ libjxl.so:graphics/libjxl \
+ libjxl_threads.so:graphics/libjxl
USES= autoreconf gmake gnome jpeg motif shebangfix xorg
USE_XORG= ice sm x11 xext xt
USE_GNOME+= libxml2
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
SHEBANG_FILES= scripts/gpx2shape
SHEBANG_REGEX= ./scripts/.*\.(sh|pl|py)
@@ -85,8 +88,4 @@ BDB_USES= bdb
BDB_CONFIGURE_ON= --with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb-libdir=${BDB_LIB_DIR}
-post-extract:
- @${REINPLACE_CMD} -e 's|2>&1||g' ${WRKSRC}/acinclude.m4
-
.include <bsd.port.mk>
-