aboutsummaryrefslogtreecommitdiff
path: root/converters/pdf2djvu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/pdf2djvu/Makefile')
-rw-r--r--converters/pdf2djvu/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index 0eaa305e79b7..24f103df8294 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -1,11 +1,12 @@
PORTNAME= pdf2djvu
-DISTVERSION= 0.9.18.2
-PORTREVISION= 1
+DISTVERSION= 0.9.19
+PORTREVISION= 3
CATEGORIES= converters
MASTER_SITES= https://github.com/jwilk/${PORTNAME}/releases/download/${PORTVERSION}/
MAINTAINER= samy.mahmoudi@gmail.com
COMMENT= Creates DjVu files from PDF files
+WWW= https://jwilk.net/software/pdf2djvu
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/COPYING
@@ -19,6 +20,7 @@ USES= autoreconf:build compiler:c++17-lang gettext-tools \
USE_CXXSTD= c++17
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
OPTIONS_DEFINE= COLOR_QUANTIZATION DOCS NLS MULTITHREADING XMP
OPTIONS_DEFAULT=COLOR_QUANTIZATION MULTITHREADING
@@ -26,32 +28,25 @@ OPTIONS_SUB= yes
COLOR_QUANTIZATION_DESC=Color quantization via GraphicsMagick++
DOCS_DESC= Generate the man page
-NLS_DESC= Native Language Support via gettext utilities
MULTITHREADING_DESC= Multithreading support via OpenMP
+NLS_DESC= Native Language Support via gettext utilities
XMP_DESC= XMP metadata support via Exiv2
-COLOR_QUANTIZATION_CONFIGURE_WITH=graphicsmagick
COLOR_QUANTIZATION_LIB_DEPENDS= \
libGraphicsMagick++.so:graphics/GraphicsMagick \
libGraphicsMagick.so:graphics/GraphicsMagick
+COLOR_QUANTIZATION_CONFIGURE_WITH=graphicsmagick
DOCS_BUILD_DEPENDS= docbook-xsl>0:textproc/docbook-xsl \
xsltproc:textproc/libxslt
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext-runtime
-
MULTITHREADING_CONFIGURE_ENABLE=openmp
-XMP_CONFIGURE_ENABLE= xmp
-XMP_LIB_DEPENDS= libexiv2.so:graphics/exiv2
-XMP_BROKEN= graphics/exiv2 and graphics/poppler disagree about usable C++ standard
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
-pre-configure:
- @cd ${WRKSRC} && ${SH} ${FILESDIR}/bootstrap
- # Poppler 20.12 no longer installs the pc file for this private backend.
- # https://github.com/jwilk/pdf2djvu/issues/144
- ${REINPLACE_CMD} -e 's|poppler-splash|poppler|g' ${WRKSRC}/configure
+XMP_LIB_DEPENDS= libexiv2.so:graphics/exiv2
+XMP_CONFIGURE_ENABLE= xmp
post-build-DOCS-on:
@cd ${WRKSRC}/doc && ${GMAKE}