aboutsummaryrefslogtreecommitdiff
path: root/databases/go-pgweb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/go-pgweb/Makefile')
-rw-r--r--databases/go-pgweb/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/databases/go-pgweb/Makefile b/databases/go-pgweb/Makefile
index b8113f84e8a0..bdcb5f39c44f 100644
--- a/databases/go-pgweb/Makefile
+++ b/databases/go-pgweb/Makefile
@@ -1,18 +1,31 @@
PORTNAME= pgweb
DISTVERSIONPREFIX= v
DISTVERSION= 0.11.7
+PORTREVISION= 19
CATEGORIES= databases www
PKGNAMEPREFIX= go-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= daniel@morante.net
COMMENT= Web-based database browser for PostgreSQL
+WWW= https://github.com/sosedoff/pgweb
LICENSE= MIT
USES= go
USE_GITHUB= yes
GH_ACCOUNT= sosedoff
+USE_RC_SUBR= ${PORTNAME}
+
GO_PKGNAME= github.com/sosedoff/pgweb
+
+SUB_FILES+= pkg-message
+SUB_LIST+= PGWEBGROUP=${GROUPS} \
+ PGWEBUSER=${USERS} \
+ PORTNAME=${PORTNAME}
+
PLIST_FILES= bin/pgweb
+USERS= www
+GROUPS= www
+
.include <bsd.port.mk>