aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/grass7/Makefile')
-rw-r--r--databases/grass7/Makefile44
1 files changed, 13 insertions, 31 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 6833baf7a306..49ecd791b789 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -1,8 +1,6 @@
-# Created by: Mikael URANKAR and Loïc BARTOLETTI
-
PORTNAME= grass
-PORTVERSION= 7.8.5
-PORTREVISION= 4
+PORTVERSION= 7.8.8
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -20,12 +18,11 @@ PKGNAMESUFFIX= 7
MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= Open source Geographical Information System (GIS)
+WWW= https://grass.osgeo.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
-BROKEN_sparc64= Does not configure on sparc64
-
BUILD_DEPENDS= ${PY_NUMPY} \
${PYTHON_SITELIBDIR}/six.py:devel/py-six@${PY_FLAVOR}
LIB_DEPENDS= libgdal.so:graphics/gdal \
@@ -40,7 +37,7 @@ RUN_DEPENDS= ${PY_NUMPY} \
${PYTHON_SITELIBDIR}/six.py:devel/py-six@${PY_FLAVOR}
USES= blaslapack compiler:c11 gl gmake gnome iconv \
- jpeg perl5 pkgconfig python:3.6+ readline shebangfix xorg
+ jpeg perl5 pkgconfig python readline shebangfix xorg
SHEBANG_GLOB= *.py
SHEBANG_LANG= nviz
nviz_OLD_CMD= nviz
@@ -48,8 +45,8 @@ nviz_CMD= ${PREFIX}/${GRASS_INST_DIR}/bin/nviz
USE_XORG= sm ice x11 xext xi xmu xrender xt
USE_GL= gl glu
USE_GNOME= cairo
-USE_WX= 3.0
-WX_COMPS= wx:build python:run
+USE_WX= 3.2
+WX_COMPS= wx python:run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
@@ -71,7 +68,6 @@ CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
--with-geos=${LOCALBASE}/bin/geos-config \
--with-gdal=${LOCALBASE}/bin/gdal-config \
--with-pthread=yes \
- --with-openmp \
--prefix=${LOCALBASE} \
--exec-prefix=${LOCALBASE}
@@ -89,12 +85,12 @@ PLIST_SUB= GRASS_INST_DIR="${GRASS_INST_DIR}" \
VERSION="${PORTVERSION}" VERS="${PORTVERSION:C/([0-9]+).([0-9]+)(.*)/\1.\2/}" \
VER="${VER}" MAJVER="${PKGNAMESUFFIX}"
-OPTIONS_DEFINE= LAS NETCDF NLS PDAL ZSTD
+OPTIONS_DEFINE= NETCDF NLS PDAL ZSTD
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL ODBC PGSQL SQLITE
#OPTIONS_SINGLE= BLAS
#OPTIONS_SINGLE_BLAS= ATLAS NETLIB GOTOBLAS OPENBLAS
-OPTIONS_DEFAULT= LAS NETCDF NLS PDAL PGSQL SQLITE ZSTD
+OPTIONS_DEFAULT= NETCDF NLS PDAL PGSQL SQLITE ZSTD
OPTIONS_SUB= yes
# BLAS/LAPACK: Only netlib compile the maxmimum number of modules
@@ -104,14 +100,8 @@ OPTIONS_SUB= yes
#NETLIB_USES= blaslapack
#GOTOBLAS_USES= blaslapack:gotoblas
#OPENBLAS_USES= blaslapack:openblas
-LAS_DESC= Enable LiDAR modules
PDAL_DESC= Enable points cloud data modules
DB_DESC= Database support
-LAS_CONFIGURE_ON= --with-liblas=yes
-LAS_LIB_DEPENDS= liblas.so:devel/liblas \
- libboost_program_options.so:devel/boost-libs \
- libboost_thread.so:devel/boost-libs \
- libgeotiff.so:graphics/libgeotiff
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql \
--with-mysql-includes=${LOCALBASE}/include/mysql \
@@ -123,7 +113,7 @@ NLS_USES= gettext
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
ODBC_CONFIGURE_WITH= odbc
PDAL_CONFIGURE_ON= --with-pdal=${LOCALBASE}/bin/pdal-config
-PDAL_LIB_DEPENDS= libpdal_base.so:math/pdal
+PDAL_LIB_DEPENDS= libpdalcpp.so:math/pdal
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgres
SQLITE_USES= sqlite
@@ -132,6 +122,10 @@ SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_F
ZSTD_CONFIGURE_WITH= zstd
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
+.if exists(/usr/include/omp.h)
+CONFIGURE_ARGS+= --with-openmp
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -148,18 +142,6 @@ GRASS_INST_DIR= ${PORTNAME}${VER}
MANDIRS= ${PREFIX}/grass${VER}/docs/man/man1
post-patch:
- ${REINPLACE_CMD} -e \
- 's|make -C|$$(MAKE) -C| ; \
- /^BINDIR/s|=.*|= $${DESTDIR}$${UNIX_BIN}| ; \
- /test /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /tar /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /chmod /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /tar /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /rm /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /$$(MAKE) /s| $$(INST_DIR)| $${DESTDIR}$${INST_DIR}|g ; \
- /^$$(INST_DIR)\//s|$$(INST_DIR)|$${DESTDIR}$${INST_DIR}|g ; \
- s|> $$(INST_DIR)|> $${DESTDIR}$${INST_DIR}|' \
- ${WRKSRC}/include/Make/Install.make
${REINPLACE_CMD} \
's|= python3|= ${PYTHON_CMD:T}|' ${WRKSRC}/include/Make/Platform.make.in
${REINPLACE_CMD} -e \