aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/kbibtex/Makefile')
-rw-r--r--databases/kbibtex/Makefile54
1 files changed, 25 insertions, 29 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 05f420b2dae8..7a0d7b2e5c54 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -1,46 +1,42 @@
-# Created by: Markus Brueffer <markus@FreeBSD.org>
-
PORTNAME= kbibtex
-DISTVERSION= 0.9.2
-PORTREVISION= 20
+DISTVERSION= 0.10.0
+PORTREVISION= 9
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Bibliography editor for KDE
+WWW= https://userbase.kde.org/KBibTeX
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicuuc.so:devel/icu \
libpoppler.so:graphics/poppler \
- libpoppler-qt5.so:graphics/poppler-qt5 \
- libqoauth-qt5.so:net/qoauth-qt5
+ libpoppler-qt5.so:graphics/poppler-qt5
-USES= cmake compiler:c++11-lang desktop-file-utils gettext gnome \
- iconv kde:5 qca qt:5 shared-mime-info tar:xz
-USE_GNOME= libxml2 libxslt
+USES= cmake compiler:c++11-lang desktop-file-utils gettext-tools \
+ kde:5 pkgconfig qt:5 shared-mime-info tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
- kio parts service solid sonnet texteditor textwidgets wallet \
- widgetsaddons windowsystem xmlgui \
- doctools_build
-USE_QT= concurrent core dbus declarative gui location network \
- printsupport webchannel widgets xml xmlpatterns \
- buildtools_build qmake_build
+ coreaddons crash i18n iconthemes itemviews jobwidgets kio \
+ parts service solid sonnet syntaxhighlighting texteditor \
+ textwidgets wallet widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build
+USE_QT= concurrent core dbus gui location network networkauth \
+ widgets xml xmlpatterns \
+ buildtools:build qmake:build
+USE_XORG= x11
USE_LDCONFIG= yes
-OPTIONS_DEFINE= WEBENGINE
-OPTIONS_DEFAULT_amd64= WEBENGINE
-OPTIONS_DEFAULT_i386= WEBENGINE
+CMAKE_ARGS+= -DKDE_INSTALL_MANDIR:PATH=${PREFIX}/share/man
-WEBENGINE_DESC= Add dependency on qt5-webengine
-WEBENGINE_USE= QT=webengine
-WEBENGINE_USE_OFF= QT=webkit
-WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
+OPTIONS_DEFINE= WEBENGINE
+OPTIONS_DEFAULT_aarch64= WEBENGINE
+OPTIONS_DEFAULT_amd64= WEBENGINE
+OPTIONS_DEFAULT_i386= WEBENGINE
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWEBENGINE}
-DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
-EXPIRATION_DATE=2021-06-23
-.endif
+WEBENGINE_DESC= Webpage rendering support
+WEBENGINE_USE= QT=declarative,printsupport,webchannel,webengine
+WEBENGINE_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets
.include <bsd.port.mk>