aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex
diff options
context:
space:
mode:
Diffstat (limited to 'databases/kbibtex')
-rw-r--r--databases/kbibtex/Makefile26
-rw-r--r--databases/kbibtex/distinfo6
-rw-r--r--databases/kbibtex/pkg-plist202
3 files changed, 61 insertions, 173 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index cb511a0e5490..9fba4bea1f64 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -2,23 +2,29 @@
# $FreeBSD$
PORTNAME= kbibtex
-DISTVERSION= 0.6.2
-PORTREVISION= 4
+DISTVERSION= 0.8.1
CATEGORIES= databases kde
-MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:R}/
+MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}/
MAINTAINER= kde@FreeBSD.org
COMMENT= Bibliography editor for KDE
-LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
- libqca.so:devel/qca@qt4 \
- libqoauth.so:net/qoauth
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libqca-qt5.so:devel/qca@qt5 \
+ libpoppler.so:graphics/poppler \
+ libpoppler-qt5.so:graphics/poppler-qt5 \
+ libqoauth-qt5.so:net/qoauth-qt5
-USES= cmake gettext iconv kde:4 qt:4 shared-mime-info tar:xz
+USES= cmake desktop-file-utils gettext iconv kde:5 qt:5 \
+ shared-mime-info tar:xz
USE_GNOME= libxml2 libxslt
-USE_KDE= kdelibs automoc4
-USE_QT= qmake_build moc_build uic_build rcc_build \
- webkit
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
+ kio parts service solid sonnet textwidgets wallet \
+ widgetsaddons xmlgui
+USE_QT= concurrent core dbus gui location network printsupport qml \
+ quick webchannel webengine widgets xml xmlpatterns \
+ buildtools_build qmake_build
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/databases/kbibtex/distinfo b/databases/kbibtex/distinfo
index adefb11d1910..2b183f2b74cb 100644
--- a/databases/kbibtex/distinfo
+++ b/databases/kbibtex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490015605
-SHA256 (kbibtex-0.6.2.tar.xz) = d99e419aec1d3af0a57eba6d7498de4e6be25ddbd5a5e56fc9de09e7e17dcdf3
-SIZE (kbibtex-0.6.2.tar.xz) = 3081364
+TIMESTAMP = 1538908614
+SHA256 (kbibtex-0.8.1.tar.xz) = 6511a912925c628b7d175b0ef98ba98b1b8eb61e457d621ea0963d29b1fd21d2
+SIZE (kbibtex-0.8.1.tar.xz) = 4060484
diff --git a/databases/kbibtex/pkg-plist b/databases/kbibtex/pkg-plist
index 00e4e68ade2d..d283fff9ac5f 100644
--- a/databases/kbibtex/pkg-plist
+++ b/databases/kbibtex/pkg-plist
@@ -1,157 +1,38 @@
bin/kbibtex
-include/kde4/kbibtex/api.h
-include/kde4/kbibtex/associatedfiles.h
-include/kde4/kbibtex/associatedfilesui.h
-include/kde4/kbibtex/basicfileview.h
-include/kde4/kbibtex/bibliographyservice.h
-include/kde4/kbibtex/bibtexentries.h
-include/kde4/kbibtex/bibtexfields.h
-include/kde4/kbibtex/bibutils.h
-include/kde4/kbibtex/checkbibtex.h
-include/kde4/kbibtex/clipboard.h
-include/kde4/kbibtex/collection.h
-include/kde4/kbibtex/collectionmodel.h
-include/kde4/kbibtex/colorlabelwidget.h
-include/kde4/kbibtex/comment.h
-include/kde4/kbibtex/delayedexecutiontimer.h
-include/kde4/kbibtex/element.h
-include/kde4/kbibtex/elementeditor.h
-include/kde4/kbibtex/encoder.h
-include/kde4/kbibtex/encoderlatex.h
-include/kde4/kbibtex/encoderutf8.h
-include/kde4/kbibtex/encoderxml.h
-include/kde4/kbibtex/entry.h
-include/kde4/kbibtex/fieldinput.h
-include/kde4/kbibtex/fieldlineedit.h
-include/kde4/kbibtex/file.h
-include/kde4/kbibtex/fileexporter.h
-include/kde4/kbibtex/fileexporterbibtex.h
-include/kde4/kbibtex/fileexporterbibtex2html.h
-include/kde4/kbibtex/fileexporterbibtexoutput.h
-include/kde4/kbibtex/fileexporterbibutils.h
-include/kde4/kbibtex/fileexporterpdf.h
-include/kde4/kbibtex/fileexporterps.h
-include/kde4/kbibtex/fileexporterris.h
-include/kde4/kbibtex/fileexporterrtf.h
-include/kde4/kbibtex/fileexportertoolchain.h
-include/kde4/kbibtex/fileexporterxml.h
-include/kde4/kbibtex/fileexporterxslt.h
-include/kde4/kbibtex/fileimporter.h
-include/kde4/kbibtex/fileimporterbibtex.h
-include/kde4/kbibtex/fileimporterbibutils.h
-include/kde4/kbibtex/fileimporterpdf.h
-include/kde4/kbibtex/fileimporterris.h
-include/kde4/kbibtex/fileinfo.h
-include/kde4/kbibtex/filemodel.h
-include/kde4/kbibtex/fileview.h
-include/kde4/kbibtex/filterbar.h
-include/kde4/kbibtex/findduplicates.h
-include/kde4/kbibtex/findduplicatesui.h
-include/kde4/kbibtex/findpdf.h
-include/kde4/kbibtex/findpdfui.h
-include/kde4/kbibtex/groups.h
-include/kde4/kbibtex/guihelper.h
-include/kde4/kbibtex/iconvlatex.h
-include/kde4/kbibtex/idsuggestions.h
-include/kde4/kbibtex/internalnetworkaccessmanager.h
-include/kde4/kbibtex/iocommon.h
-include/kde4/kbibtex/italictextitemmodel.h
-include/kde4/kbibtex/items.h
-include/kde4/kbibtex/journalabbreviations.h
-include/kde4/kbibtex/kbibtexdata_export.h
-include/kde4/kbibtex/kbibtexgui_export.h
-include/kde4/kbibtex/kbibtexio_export.h
-include/kde4/kbibtex/kbibtexnamespace.h
-include/kde4/kbibtex/kbibtexnetworking_export.h
-include/kde4/kbibtex/kbibtexpreferencesdialog.h
-include/kde4/kbibtex/kbibtexproc_export.h
-include/kde4/kbibtex/lyx.h
-include/kde4/kbibtex/macro.h
-include/kde4/kbibtex/oauthwizard.h
-include/kde4/kbibtex/onlinesearchabstract.h
-include/kde4/kbibtex/onlinesearchacmportal.h
-include/kde4/kbibtex/onlinesearcharxiv.h
-include/kde4/kbibtex/onlinesearchbibsonomy.h
-include/kde4/kbibtex/onlinesearchcernds.h
-include/kde4/kbibtex/onlinesearchdoi.h
-include/kde4/kbibtex/onlinesearchgeneral.h
-include/kde4/kbibtex/onlinesearchgooglescholar.h
-include/kde4/kbibtex/onlinesearchideasrepec.h
-include/kde4/kbibtex/onlinesearchieeexplore.h
-include/kde4/kbibtex/onlinesearchingentaconnect.h
-include/kde4/kbibtex/onlinesearchinspirehep.h
-include/kde4/kbibtex/onlinesearchisbndb.h
-include/kde4/kbibtex/onlinesearchjstor.h
-include/kde4/kbibtex/onlinesearchmathscinet.h
-include/kde4/kbibtex/onlinesearchmrlookup.h
-include/kde4/kbibtex/onlinesearchpubmed.h
-include/kde4/kbibtex/onlinesearchsciencedirect.h
-include/kde4/kbibtex/onlinesearchsimplebibtexdownload.h
-include/kde4/kbibtex/onlinesearchsoanasaads.h
-include/kde4/kbibtex/onlinesearchspringerlink.h
-include/kde4/kbibtex/partwidget.h
-include/kde4/kbibtex/preamble.h
-include/kde4/kbibtex/settingsabstractwidget.h
-include/kde4/kbibtex/settingscolorlabelwidget.h
-include/kde4/kbibtex/settingsfileexporterpdfpswidget.h
-include/kde4/kbibtex/settingsfileexporterwidget.h
-include/kde4/kbibtex/settingsgeneralwidget.h
-include/kde4/kbibtex/settingsglobalkeywordswidget.h
-include/kde4/kbibtex/settingsidsuggestionseditor.h
-include/kde4/kbibtex/settingsidsuggestionswidget.h
-include/kde4/kbibtex/settingsuserinterfacewidget.h
-include/kde4/kbibtex/tagmodel.h
-include/kde4/kbibtex/tags.h
-include/kde4/kbibtex/value.h
-include/kde4/kbibtex/valuelistmodel.h
-include/kde4/kbibtex/xsltransform.h
-lib/kde4/kbibtexpart.so
+etc/xdg/kbibtexrc
lib/libkbibtexconfig.so
-lib/libkbibtexconfig.so.0.6
-lib/libkbibtexconfig.so.0.6.1
+lib/libkbibtexconfig.so.0
+lib/libkbibtexconfig.so.0.8
lib/libkbibtexdata.so
-lib/libkbibtexdata.so.0.6
-lib/libkbibtexdata.so.0.6.1
+lib/libkbibtexdata.so.0
+lib/libkbibtexdata.so.0.8
lib/libkbibtexgui.so
-lib/libkbibtexgui.so.0.6
-lib/libkbibtexgui.so.0.6.1
+lib/libkbibtexgui.so.0
+lib/libkbibtexgui.so.0.8
lib/libkbibtexio.so
-lib/libkbibtexio.so.0.6
-lib/libkbibtexio.so.0.6.1
+lib/libkbibtexio.so.0
+lib/libkbibtexio.so.0.8
lib/libkbibtexnetworking.so
-lib/libkbibtexnetworking.so.0.6
-lib/libkbibtexnetworking.so.0.6.1
+lib/libkbibtexnetworking.so.0
+lib/libkbibtexnetworking.so.0.8
lib/libkbibtexproc.so
-lib/libkbibtexproc.so.0.6
-lib/libkbibtexproc.so.0.6.1
-share/appdata/kbibtex.appdata.xml
-share/applications/kde4/kbibtex.desktop
-share/apps/kbibtex/abstractonly.xsl
-share/apps/kbibtex/arxiv2bibtex.xsl
-share/apps/kbibtex/biblatex.kbstyle
-share/apps/kbibtex/bibtex.kbstyle
-share/apps/kbibtex/fancy.xsl
-share/apps/kbibtex/ieeexplore2bibtex.xsl
-share/apps/kbibtex/isbndb2bibtex.xsl
-share/apps/kbibtex/jabref_journalabbrevlist.txt
-share/apps/kbibtex/kbibtexui.rc
-share/apps/kbibtex/pam2bibtex.xsl
-share/apps/kbibtex/pubmed2bibtex.xsl
-share/apps/kbibtex/standard.xsl
-share/apps/kbibtex/wikipedia-cite.xsl
-share/apps/kbibtex/worldcatdc2bibtex.xsl
-share/apps/kbibtexpart/kbibtexpartui.rc
-share/config/kbibtexrc
-share/doc/HTML/de/kbibtex/common
+lib/libkbibtexproc.so.0
+lib/libkbibtexproc.so.0.8
+%%QT_PLUGINDIR%%/kbibtexpart.so
+man/ca/man1/kbibtex.1.gz
+man/de/man1/kbibtex.1.gz
+man/it/man1/kbibtex.1.gz
+man/man1/kbibtex.1.gz
+man/nl/man1/kbibtex.1.gz
+man/uk/man1/kbibtex.1.gz
+share/applications/org.kde.kbibtex.desktop
share/doc/HTML/de/kbibtex/index.cache.bz2
share/doc/HTML/de/kbibtex/index.docbook
-share/doc/HTML/de/kbibtex/man-kbibtex.1.docbook
share/doc/HTML/en/kbibtex/add-macro-source.png
share/doc/HTML/en/kbibtex/add-macro.png
share/doc/HTML/en/kbibtex/application-pdf.png
share/doc/HTML/en/kbibtex/applications-internet.png
share/doc/HTML/en/kbibtex/code-context.png
-share/doc/HTML/en/kbibtex/common
share/doc/HTML/en/kbibtex/config-color.png
share/doc/HTML/en/kbibtex/config-general.png
share/doc/HTML/en/kbibtex/config-id-suggestions.png
@@ -189,7 +70,6 @@ share/doc/HTML/en/kbibtex/list-of-values.png
share/doc/HTML/en/kbibtex/list-remove.png
share/doc/HTML/en/kbibtex/lyx-preferences.png
share/doc/HTML/en/kbibtex/main-toolbar.png
-share/doc/HTML/en/kbibtex/man-kbibtex.1.docbook
share/doc/HTML/en/kbibtex/media-playback-start.png
share/doc/HTML/en/kbibtex/new-document.png
share/doc/HTML/en/kbibtex/online-search.png
@@ -201,29 +81,12 @@ share/doc/HTML/en/kbibtex/svn-update.png
share/doc/HTML/en/kbibtex/tools-check-spelling.png
share/doc/HTML/en/kbibtex/view-filter.png
share/doc/HTML/en/kbibtex/zotero.png
-share/doc/HTML/et/kbibtex/common
-share/doc/HTML/et/kbibtex/index.cache.bz2
-share/doc/HTML/et/kbibtex/index.docbook
-share/doc/HTML/et/kbibtex/man-kbibtex.1.docbook
-share/doc/HTML/it/kbibtex/common
share/doc/HTML/it/kbibtex/index.cache.bz2
share/doc/HTML/it/kbibtex/index.docbook
-share/doc/HTML/it/kbibtex/man-kbibtex.1.docbook
-share/doc/HTML/nl/kbibtex/common
share/doc/HTML/nl/kbibtex/index.cache.bz2
share/doc/HTML/nl/kbibtex/index.docbook
-share/doc/HTML/nl/kbibtex/man-kbibtex.1.docbook
-share/doc/HTML/pt_BR/kbibtex/common
-share/doc/HTML/pt_BR/kbibtex/index.cache.bz2
-share/doc/HTML/pt_BR/kbibtex/index.docbook
-share/doc/HTML/pt_BR/kbibtex/man-kbibtex.1.docbook
-share/doc/HTML/sv/kbibtex/common
-share/doc/HTML/sv/kbibtex/index.cache.bz2
-share/doc/HTML/sv/kbibtex/index.docbook
-share/doc/HTML/sv/kbibtex/man-kbibtex.1.docbook
share/doc/HTML/uk/kbibtex/add-macro-source.png
share/doc/HTML/uk/kbibtex/add-macro.png
-share/doc/HTML/uk/kbibtex/common
share/doc/HTML/uk/kbibtex/config-color.png
share/doc/HTML/uk/kbibtex/config-general.png
share/doc/HTML/uk/kbibtex/config-id-suggestions.png
@@ -246,7 +109,6 @@ share/doc/HTML/uk/kbibtex/list-of-documents.png
share/doc/HTML/uk/kbibtex/list-of-values.png
share/doc/HTML/uk/kbibtex/lyx-preferences.png
share/doc/HTML/uk/kbibtex/main-toolbar.png
-share/doc/HTML/uk/kbibtex/man-kbibtex.1.docbook
share/doc/HTML/uk/kbibtex/new-document.png
share/doc/HTML/uk/kbibtex/online-search.png
share/doc/HTML/uk/kbibtex/reference-preview.png
@@ -259,7 +121,22 @@ share/icons/hicolor/22x22/apps/kbibtex.png
share/icons/hicolor/32x32/apps/kbibtex.png
share/icons/hicolor/48x48/apps/kbibtex.png
share/icons/hicolor/64x64/apps/kbibtex.png
-share/kde4/services/kbibtexpart.desktop
+%%DATADIR%%/abstractonly.xsl
+%%DATADIR%%/arxiv2bibtex.xsl
+%%DATADIR%%/biblatex.kbstyle
+%%DATADIR%%/bibtex.kbstyle
+%%DATADIR%%/fancy.xsl
+%%DATADIR%%/ieeexplore2bibtex.xsl
+%%DATADIR%%/isbndb2bibtex.xsl
+%%DATADIR%%/jabref_journalabbrevlist.txt
+%%DATADIR%%/pam2bibtex.xsl
+%%DATADIR%%/pubmed2bibtex.xsl
+%%DATADIR%%/standard.xsl
+%%DATADIR%%/wikipedia-cite.xsl
+%%DATADIR%%/worldcatdc2bibtex.xsl
+share/kservices5/kbibtexpart.desktop
+share/kxmlgui5/kbibtex/kbibtexui.rc
+share/kxmlgui5/kbibtexpart/kbibtexpartui.rc
share/locale/ast/LC_MESSAGES/kbibtex.mo
share/locale/bs/LC_MESSAGES/kbibtex.mo
share/locale/ca/LC_MESSAGES/kbibtex.mo
@@ -273,6 +150,7 @@ share/locale/fi/LC_MESSAGES/kbibtex.mo
share/locale/fr/LC_MESSAGES/kbibtex.mo
share/locale/gl/LC_MESSAGES/kbibtex.mo
share/locale/hu/LC_MESSAGES/kbibtex.mo
+share/locale/ia/LC_MESSAGES/kbibtex.mo
share/locale/it/LC_MESSAGES/kbibtex.mo
share/locale/ja/LC_MESSAGES/kbibtex.mo
share/locale/lt/LC_MESSAGES/kbibtex.mo
@@ -285,5 +163,9 @@ share/locale/pt_BR/LC_MESSAGES/kbibtex.mo
share/locale/ru/LC_MESSAGES/kbibtex.mo
share/locale/sk/LC_MESSAGES/kbibtex.mo
share/locale/sv/LC_MESSAGES/kbibtex.mo
+share/locale/tr/LC_MESSAGES/kbibtex.mo
share/locale/uk/LC_MESSAGES/kbibtex.mo
+share/locale/zh_CN/LC_MESSAGES/kbibtex.mo
+share/locale/zh_TW/LC_MESSAGES/kbibtex.mo
+share/metainfo/org.kde.kbibtex.appdata.xml
share/mime/packages/bibliography.xml