aboutsummaryrefslogtreecommitdiff
path: root/databases/memcached/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/memcached/Makefile')
-rw-r--r--databases/memcached/Makefile42
1 files changed, 16 insertions, 26 deletions
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index 8afa63b83ab0..e8ef24a56257 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -1,62 +1,52 @@
-# Created by: Sean Chittenden <seanc@FreeBSD.org>
-
PORTNAME= memcached
-PORTVERSION= 1.6.12
+PORTVERSION= 1.6.26
CATEGORIES= databases
MASTER_SITES= http://www.memcached.org/files/ \
GENTOO
-MAINTAINER= swills@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= High-performance distributed memory object cache system
+WWW= https://memcached.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libevent.so:devel/libevent
-USES= autoreconf cpe shebangfix
-SHEBANG_FILES= scripts/memcached-tool
-
+USES= autoreconf cpe pkgconfig shebangfix
+USE_CSTD= c99
USE_RC_SUBR= memcached
-SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
-USE_CSTD= c99
-GNU_CONFIGURE= yes
+SHEBANG_FILES= scripts/memcached-tool
+
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-coverage \
--program-prefix= \
--with-libevent=${LOCALBASE}
+MAKE_JOBS_UNSAFE= yes
+
+SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
+
# Dtrace option disabled until it is fixed upstream
OPTIONS_DEFINE= DOCS SASL
-OPTIONS_DEFAULT= SASL
OPTIONS_DEFINE_amd64= DTRACE
-OPTIONS_DEFAULT_amd64= DTRACE
OPTIONS_DEFINE_powerpc64= DTRACE
-OPTIONS_DEFAULT_powerpc64= DTRACE
-OPTIONS_EXCLUDE_powerpc64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
-OPTIONS_EXCLUDE_powerpc64_12= DTRACE
OPTIONS_DEFINE_powerpc64le= DTRACE
+OPTIONS_DEFAULT= SASL
+OPTIONS_DEFAULT_amd64= DTRACE
+OPTIONS_DEFAULT_powerpc64= DTRACE
OPTIONS_DEFAULT_powerpc64le= DTRACE
-.if !exists(/usr/sbin/dtrace)
-OPTIONS_EXCLUDE+= DTRACE
-.endif
-
DTRACE_DESC= Enable dtrace probes
SASL_DESC= Enable SASL Authentication
DOCS_BUILD_DEPENDS= xml2rfc:textproc/xml2rfc
DOCS_CONFIGURE_ENABLE= docs
-
DTRACE_CONFIGURE_ENABLE= dtrace
-
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+SASL_USES= localbase:ldflags
SASL_CONFIGURE_ENABLE= sasl
-SASL_CFLAGS= -I${LOCALBASE}/include
-SASL_CPPFLAGS+= ${CFLAGS}
-SASL_LDFLAGS= -L${LOCALBASE}/lib
-
-MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>