aboutsummaryrefslogtreecommitdiff
path: root/databases/pgroonga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/pgroonga/Makefile')
-rw-r--r--databases/pgroonga/Makefile30
1 files changed, 8 insertions, 22 deletions
diff --git a/databases/pgroonga/Makefile b/databases/pgroonga/Makefile
index 8a543d73b880..cfce2e385887 100644
--- a/databases/pgroonga/Makefile
+++ b/databases/pgroonga/Makefile
@@ -1,43 +1,29 @@
-# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
-
PORTNAME= pgroonga
-PORTVERSION= 2.3.4
+PORTVERSION= 3.0.2
CATEGORIES= databases textproc
MASTER_SITES= http://packages.groonga.org/source/pgroonga/
MAINTAINER= bofh@FreeBSD.org
COMMENT= Open-source fulltext search engine for PostGRESQL
+WWW= https://pgroonga.github.io/
LICENSE= PostgreSQL
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgroonga.so:textproc/groonga
-USES= gmake pgsql:9.6+ pkgconfig
+USES= gmake localbase pgsql:11+ pkgconfig
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/groonga
+CPPFLAGS+= -I${LOCALBASE}/include/groonga
LLD_UNSAFE= yes
SUB_FILES= pkg-message
PLIST_SUB= MVER=${PORTVERSION}
-OPTIONS_DEFINE= MECAB
-MECAB_DESC= Use MeCab as a tokenizer
+OPTIONS_DEFINE= MECAB
+MECAB_DESC= Use MeCab as a tokenizer
MECAB_BUILD_DEPENDS= mecab-ipadics>=0.996:japanese/mecab-ipadic
-.include <bsd.port.pre.mk>
-# With PG11+ some scripts are only installed when they are common to
-# all PG versions.
-.if ${PGSQL_VER:R} < 11
-PLIST_SUB+= OLDPG="@comment "
-.else
-PLIST_SUB+= OLDPG=""
-.endif
-
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga_check.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga_crash_safer.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga_database.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga_wal_applier.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pgroonga*.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>