aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql92-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql92-server/Makefile')
-rw-r--r--databases/postgresql92-server/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 2e30cb0dcb70..920f675abe20 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -3,7 +3,7 @@
# Date created: November 13, 1998
# Whom: Marc G. Fournier <scrappy@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.43 1999/06/29 20:21:18 andreas Exp $
+# $Id: Makefile,v 1.44 1999/07/21 07:16:25 andreas Exp $
#
DISTNAME= postgresql-6.5.1
@@ -159,14 +159,14 @@ post-install:
${ECHO} "#export TZ" \
>> ${PREFIX}/pgsql/.profile; \
fi
- @ chown -R pgsql:pgsql ${PREFIX}/pgsql
+ @ ${CHOWN} -R pgsql:pgsql ${PREFIX}/pgsql
@ ${ECHO} 'Initializing PostgreSQL Databases - this may take a few minutes...'
@ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/pgsql/lib
@ su -l pgsql -c 'PATH=${PREFIX}/pgsql/bin:${PATH} ${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data'
@ ${SED} -e "s=!!PREFIX!!=${PREFIX}=g" < ${FILESDIR}/pgsql.sh.tmpl \
> ${PREFIX}/etc/rc.d/pgsql.sh
- @ chmod 554 ${PREFIX}/etc/rc.d/pgsql.sh
- @ chown root.pgsql ${PREFIX}/etc/rc.d/pgsql.sh
+ @ ${CHMOD} 554 ${PREFIX}/etc/rc.d/pgsql.sh
+ @ ${CHOWN} root.pgsql ${PREFIX}/etc/rc.d/pgsql.sh
@ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/pgsql
.if defined(USE_TCL)