aboutsummaryrefslogtreecommitdiff
path: root/databases/py-psycopg-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-psycopg-c/Makefile')
-rw-r--r--databases/py-psycopg-c/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/py-psycopg-c/Makefile b/databases/py-psycopg-c/Makefile
new file mode 100644
index 000000000000..124ebded1fcf
--- /dev/null
+++ b/databases/py-psycopg-c/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= psycopg-c
+PORTVERSION= 3.1.18
+CATEGORIES= databases python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PostgreSQL database adapter for Python - C optimization distribution
+WWW= https://www.psycopg.org/psycopg3/ \
+ https://github.com/psycopg/psycopg/tree/master/psycopg_c
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=49.2.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomli>=2.0.1:textproc/py-tomli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.37:devel/py-wheel@${PY_FLAVOR}
+
+USES= pgsql python
+USE_PYTHON= autoplist concurrent cython pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>