aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-postgres/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/rubygem-postgres/Makefile')
-rw-r--r--databases/rubygem-postgres/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/databases/rubygem-postgres/Makefile b/databases/rubygem-postgres/Makefile
deleted file mode 100644
index 4abade5f551c..000000000000
--- a/databases/rubygem-postgres/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: ruby-postgres
-# Date created: 19 April 1999
-# Whom: Yasuhiro Fukuma <yasuf@big.or.jp>
-#
-# $FreeBSD$
-#
-
-PORTNAME= postgres
-PORTVERSION= 0.7.1
-PORTREVISION= 2
-CATEGORIES= databases ruby
-MASTER_SITES= http://ruby.scripting.ca/postgres/archive/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Ruby interface to PostgreSQL library
-
-USE_PGSQL= yes
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-CONFIGURE_ARGS= --with-pgsql-include-dir="${LOCALBASE}/include"
-INSTALL_TARGET= site-install
-
-DOCS_EN= ChangeLog README doc/postgres.html
-DOCS_JA= README.ja doc/postgres.jp.html
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
-.endfor
-.endif
-
-.include <bsd.port.mk>