aboutsummaryrefslogtreecommitdiff
path: root/deskutils/copyq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/copyq/Makefile')
-rw-r--r--deskutils/copyq/Makefile60
1 files changed, 33 insertions, 27 deletions
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
index 3e2de234663e..4d47e0d153d3 100644
--- a/deskutils/copyq/Makefile
+++ b/deskutils/copyq/Makefile
@@ -1,40 +1,46 @@
PORTNAME= copyq
-DISTVERSIONPREFIX= v
-DISTVERSION= 4.1.0
+DISTVERSION= 8.0.0
CATEGORIES= deskutils
+MASTER_SITES= https://github.com/hluk/CopyQ/releases/download/v${DISTVERSION}/
+PKGNAMESUFFIX= -${FLAVOR}
+DISTNAME= CopyQ-${DISTVERSION}
MAINTAINER= eduardo@FreeBSD.org
-COMMENT= Qt5 based clipboard manager
+COMMENT= Qt${FLAVOR:S/qt//} based clipboard manager
+WWW= https://github.com/hluk/CopyQ
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/kf5-extra-cmake-modules
-
-LIB_DEPENDS= libwayland-client.so:graphics/wayland
-
-USES= cmake compiler:c++11-lang kde:5 qt:5 xorg
-USE_GITHUB= yes
-GH_ACCOUNT= hluk
-GH_PROJECT= CopyQ
-
-USE_KDE= notifications
-USE_LDCONFIG= yes
-USE_QT= core declarative gui network script svg widgets x11extras \
- imageformats_run buildtools_build linguisttools_build \
- qmake_build wayland
-USE_XORG= x11 xtst
-
-LDFLAGS+= -Wl,--as-needed
-
-OPTIONS_DEFINE= PLUGINS WEBKIT
-OPTIONS_DEFAULT= PLUGINS WEBKIT
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+
+FLAVORS= qt5 qt6
+FLAVOR?= qt5
+qt5_CONFLICTS_INSTALL= copyq-qt6
+qt6_CONFLICTS_INSTALL= copyq-qt5
+
+USES= cmake gl kde:${FLAVOR:S/qt//} pkgconfig qt:${FLAVOR:S/qt//} \
+ xorg
+USE_GL= gl
+_USE_KDE_qt5= ecm:build notifications
+_USE_KDE_qt6= ecm:build notifications statusnotifieritem
+USE_KDE= ${_USE_KDE_${FLAVOR}}
+_USE_QT5= core dbus declarative gui network svg wayland widgets x11extras \
+ xml buildtools:build qmake:build
+_USE_QT6= base declarative svg wayland translations:build
+USE_QT= ${_USE_QT${FLAVOR:S/qt//}}
+USE_XORG= ice sm x11 xext xfixes xtst
+
+_QT6_CMAKE_ARGS= -DWITH_QT6:BOOL=TRUE
+CMAKE_ARGS= ${_QT${FLAVOR:S/qt//}_CMAKE_ARGS}
+
+PORTSCOUT= limit:^d\.d\.
+
+OPTIONS_DEFINE= PLUGINS
+OPTIONS_DEFAULT= PLUGINS
OPTIONS_SUB= yes
PLUGINS_CMAKE_BOOL= WITH_PLUGINS
-WEBKIT_IMPLIES= PLUGINS
-WEBKIT_USE= qt=webkit
-WEBKIT_CMAKE_BOOL= WITH_WEBKIT
-
.include <bsd.port.mk>