aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-calendar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-calendar/Makefile')
-rw-r--r--deskutils/gnome-calendar/Makefile35
1 files changed, 19 insertions, 16 deletions
diff --git a/deskutils/gnome-calendar/Makefile b/deskutils/gnome-calendar/Makefile
index 975e3d47e5fa..31e65d8a2725 100644
--- a/deskutils/gnome-calendar/Makefile
+++ b/deskutils/gnome-calendar/Makefile
@@ -2,34 +2,37 @@
# $FreeBSD$
PORTNAME= gnome-calendar
-PORTVERSION= 3.18.2.1
-PORTREVISION= 8
+PORTVERSION= 3.28.2
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Simple and beatiful calendar application for GNOME
-PORTSCOUT= limitw:1,even
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libical.so:devel/libical
+PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
+BUILD_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
+LIB_DEPENDS= libical.so:devel/libical \
+ libdazzle-1.0.so:x11-toolkits/libdazzle \
+ libsoup-2.4.so:devel/libsoup \
+ libgweather-3.so:net/libgweather \
+ libgeoclue-2.so:net/geoclue \
+ libgeocode-glib.so:net/geocode-glib \
+ libgoa-1.0.so:net/gnome-online-accounts
+RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
+
+USES= desktop-file-utils gettext gnome localbase:ldflags meson \
+ pkgconfig python:3.4+,build tar:xz
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_GNOME= evolutiondataserver3 gtk30 intlhack \
- introspection
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_GNOME= cairo evolutiondataserver3 gtksourceview3
+BINARY_ALIAS= python3=${PYTHON_VERSION}
GLIB_SCHEMAS= org.gnome.calendar.enums.xml \
org.gnome.calendar.gschema.xml
-# for gcc 4.2.1
-post-patch:
- @${REINPLACE_CMD} -e 's|-Wempty-body||g' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>