aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-pomodoro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-pomodoro/Makefile')
-rw-r--r--deskutils/gnome-pomodoro/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/deskutils/gnome-pomodoro/Makefile b/deskutils/gnome-pomodoro/Makefile
index f3f64a51e0fe..8c503b798497 100644
--- a/deskutils/gnome-pomodoro/Makefile
+++ b/deskutils/gnome-pomodoro/Makefile
@@ -1,47 +1,36 @@
PORTNAME= gnome-pomodoro
-PORTVERSION= 0.18.0
+PORTVERSION= 0.22.1
+PORTREVISION= 1
+PORTEPOCH= 1
CATEGORIES= deskutils gnome
MAINTAINER= tagattie@FreeBSD.org
COMMENT= Time management utility for GNOME
+WWW= https://gnomepomodoro.org
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= appstream-util:devel/appstream-glib \
- autoconf-archive>0:devel/autoconf-archive \
- valac:lang/vala
+BUILD_DEPENDS= appstream-util:devel/appstream-glib
LIB_DEPENDS= libcanberra.so:audio/libcanberra \
libgom-1.0.so:databases/gom \
libpeas-1.0.so:devel/libpeas
-USES= autoreconf desktop-file-utils gettext-tools gmake gnome \
- libtool pkgconfig sqlite
+USES= gettext-tools gmake gnome gstreamer libtool meson pkgconfig \
+ sqlite vala:build
USE_GITHUB= yes
-GNU_CONFIGURE= yes
-
-# clang fails to compile a C source (gnome-shell-extension.c) generated
-# from vala source. USE_GCC=yes is a temporary workaround to this issue.
-USE_GCC= yes
USE_GNOME= cairo glib20 gtk30 introspection
-USE_GSTREAMER1= yes
-
-INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.pomodoro.gschema.xml \
org.gnome.pomodoro.plugins.actions.gschema.xml \
org.gnome.pomodoro.plugins.gnome.gschema.xml \
org.gnome.pomodoro.plugins.sounds.gschema.xml
-INSTALLS_ICONS= yes
PORTDOCS= NEWS README.md
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
-
-NLS_CONFIGURE_ENABLE= nls
+OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}