aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-shell-extension-trash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-shell-extension-trash/Makefile')
-rw-r--r--deskutils/gnome-shell-extension-trash/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/deskutils/gnome-shell-extension-trash/Makefile b/deskutils/gnome-shell-extension-trash/Makefile
index 40f0f406ba4f..400643b3ce35 100644
--- a/deskutils/gnome-shell-extension-trash/Makefile
+++ b/deskutils/gnome-shell-extension-trash/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-shell-extension-trash
-PORTVERSION= 0.0.0.20150512
+PORTVERSION= 0.0.0.20150923
CATEGORIES= deskutils gnome
DIST_SUBDIR= gnome3
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:${PORTSDIR}/x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:${PORTSDIR}/devel/gsettings-desktop-schemas
-USES= gettext gmake pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig tar:xz
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -22,15 +22,19 @@ LDFLAGS+= -L${LOCALBASE}/lib
GH_ACCOUNT= bertoldia
GH_PROJECT= gnome-shell-trash-extension
-GH_TAGNAME= 0fa1d72
+GH_TAGNAME= 56f18ae
PKGMESSAGE= ../gnome-shell-extra-extensions/pkg-message.slaves
NO_BUILD= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|"3.16"|"3.18", "3.16"|g' \
+ ${WRKSRC}/metadata.json
+
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension
- @(cd ${WRKSRC} && ${CP} -pPR * \
- ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${PREFIX}/share/gnome-shell/extensions/gnome-shell-trash-extension
.include <bsd.port.mk>