aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-todo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-todo/Makefile')
-rw-r--r--deskutils/gnome-todo/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/deskutils/gnome-todo/Makefile b/deskutils/gnome-todo/Makefile
new file mode 100644
index 000000000000..954b09d9cf73
--- /dev/null
+++ b/deskutils/gnome-todo/Makefile
@@ -0,0 +1,26 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+
+PORTNAME= gnome-todo
+PORTVERSION= 3.18.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Small application to manage your personal tasks
+
+PORTSCOUT= limitw:1,even
+
+USES= compiler:c11 gettext gmake gnome libtool \
+ pathfix pkgconfig tar:xz
+USE_GNOME= evolutiondataserver3 gnomedesktop3 gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.gnome.todo.gschema.xml
+
+.include <bsd.port.mk>