aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnote/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnote/Makefile')
-rw-r--r--deskutils/gnote/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/deskutils/gnote/Makefile b/deskutils/gnote/Makefile
index 5424248f57f0..e5732ebf5cca 100644
--- a/deskutils/gnote/Makefile
+++ b/deskutils/gnote/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gnote
-PORTVERSION= 3.16.2
-PORTREVISION= 1
+PORTVERSION= 3.18.1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
@@ -21,8 +20,8 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
USE_GNOME= gtk30 gtkmm30 intltool libxml2 libxslt
-USES= desktop-file-utils gettext gmake libtool \
- pathfix pkgconfig tar:xz
+USES= desktop-file-utils compiler:c++11-lib gettext gmake \
+ gnome libtool pathfix pkgconfig tar:xz
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -37,6 +36,12 @@ DOCS= AUTHORS ChangeLog NEWS README TODO
PLIST_SUB+= VERSION=${PORTVERSION}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+EXTRA_PATCHES= ${FILESDIR}/extra-src_base_macros.hpp
+.endif
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}