aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-kronolith/pkg-deinstall
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/horde4-kronolith/pkg-deinstall')
-rw-r--r--deskutils/horde4-kronolith/pkg-deinstall27
1 files changed, 0 insertions, 27 deletions
diff --git a/deskutils/horde4-kronolith/pkg-deinstall b/deskutils/horde4-kronolith/pkg-deinstall
deleted file mode 100644
index 4578da3f26fe..000000000000
--- a/deskutils/horde4-kronolith/pkg-deinstall
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Backup Kronolith config files, if needed.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/kronolith/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, will be deleted by pkg-plist
- ;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
- ;;
- *) # not found?
- ;;
- esac
- done
-fi