aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kcharselect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/kcharselect/Makefile')
-rw-r--r--deskutils/kcharselect/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
deleted file mode 100644
index 6667a23a3320..000000000000
--- a/deskutils/kcharselect/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# New ports collection makefile for: kdeutils3
-# Date created: 3 November 2001
-# Whom: will@cvs.kde.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= kdeutils
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 0
-CATEGORIES?= misc kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
-DIST_SUBDIR= KDE
-
-MAINTAINER?= kde@FreeBSD.org
-COMMENT= Utilities for the KDE integrated X11 desktop
-
-USE_KDELIBS_VER=3
-PREFIX= ${KDE_PREFIX}
-KDE_BUILD_PLIST=yes
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-
-#klaptop doesn't like alpha because alpha doesn't support apm
-.if ${MACHINE_ARCH} == "alpha"
-WITHOUT_KLAPTOP =yes
-.endif # ${MACHINE_ARCH} == "alpha"
-
-.if defined(WITHOUT_KLAPTOP)
-DO_NOT_COMPILE+=klaptopdaemon
-.else
-PLIST_APPEND+= plist.klaptop
-.endif # defined(WITHOUT_KLAPTOP)
-
-# kfloppy is a mostly broken, non-standard, linux-centric pain...
-.if !defined(WITH_KFLOPPY)
-DO_NOT_COMPILE+=kfloppy
-.else
-PLIST_APPEND+= plist.kfloppy
-.endif # !defined(WITH_KFLOPPY)
-
-.if defined(DO_NOT_COMPILE)
-CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
-.endif # defined(DO_NOT_COMPILE)
-
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>