aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/xpad/Makefile')
-rw-r--r--deskutils/xpad/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/deskutils/xpad/Makefile b/deskutils/xpad/Makefile
index 20f1d37e3002..8480d5cc1ee9 100644
--- a/deskutils/xpad/Makefile
+++ b/deskutils/xpad/Makefile
@@ -1,33 +1,38 @@
-# Created by: Jason Helfman <jgh@FreeBSD.org>
-
PORTNAME= xpad
-PORTVERSION= 5.4.0
+PORTVERSION= 5.8.0
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
MAINTAINER= jgh@FreeBSD.org
COMMENT= Virtual note-pad system for your X11 desktop
+WWW= https://launchpad.net/xpad/trunk
LICENSE= GPLv3
RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
+ libdbusmenu-glib.so:devel/libdbusmenu \
+ libayatana-ido3-0.4.so:devel/ayatana-ido \
+ libayatana-appindicator3.so:devel/libayatana-appindicator \
+ libayatana-indicator3.so:devel/libayatana-indicator
USES= autoreconf compiler:c++11-lang gmake pkgconfig tar:bzip2 gnome xorg
OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
-CONFLICTS_INSTALL= xpad3-[0-9]*
+CONFLICTS_INSTALL= xpad3
USE_XORG= x11 sm ice
-USE_GNOME= gtk30 intltool gtksourceview3 cairo
-INSTALLS_ICONS= yes
+USE_GNOME= gtk30 gtksourceview4 cairo gdkpixbuf2
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PORTDOCS= *
PLIST_FILES= \
bin/xpad \
-man/man1/xpad.1.gz \
+share/man/man1/xpad.1.gz \
share/applications/xpad.desktop \
share/icons/hicolor/scalable/apps/xpad.svg \
share/metainfo/xpad.appdata.xml \
@@ -67,12 +72,6 @@ share/locale/zh_TW/LC_MESSAGES/xpad.mo
.include <bsd.port.options.mk>
-post-patch:
- @${REINPLACE_CMD} -e 's|glib/glist.h|glib.h|g' \
- ${WRKSRC}/src/xpad-undo.c
- @${REINPLACE_CMD} -e 's|/etc/xdg/autostart|${LOCALBASE}/etc/xdg/autostart|g' \
- ${WRKSRC}/Makefile.am
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in AUTHORS ChangeLog INSTALL NEWS README TODO THANKS