aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-diffobj/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/R-cran-diffobj/Makefile')
-rw-r--r--devel/R-cran-diffobj/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/R-cran-diffobj/Makefile b/devel/R-cran-diffobj/Makefile
new file mode 100644
index 000000000000..0ea79d1826fb
--- /dev/null
+++ b/devel/R-cran-diffobj/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= diffobj
+DISTVERSION= 0.3.2
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Diffs for R Objects
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= R-cran-knitr>0:print/R-cran-knitr
+RUN_DEPENDS= R-cran-crayon>=1.3.2:devel/R-cran-crayon
+TEST_DEPENDS= R-cran-testthat>0:devel/R-cran-testthat \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>