aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-fontawesome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/R-cran-fontawesome/Makefile')
-rw-r--r--devel/R-cran-fontawesome/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/R-cran-fontawesome/Makefile b/devel/R-cran-fontawesome/Makefile
new file mode 100644
index 000000000000..5427293fa5b9
--- /dev/null
+++ b/devel/R-cran-fontawesome/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= fontawesome
+PORTVERSION= 0.5.2
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= Easily Work with 'Font Awesome' Icons
+WWW= https://cran.r-project.org/web/packages/fontawesome/
+
+LICENSE= MIT
+
+CRAN_DEPENDS= R-cran-rlang>=1.0.6:devel/R-cran-rlang \
+ R-cran-htmltools>=0.5.1.1:textproc/R-cran-htmltools
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+TEST_DEPENDS= R-cran-dplyr>0:math/R-cran-dplyr \
+ R-cran-testthat>0:devel/R-cran-testthat
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>