aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-future.apply/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/R-cran-future.apply/Makefile')
-rw-r--r--devel/R-cran-future.apply/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/R-cran-future.apply/Makefile b/devel/R-cran-future.apply/Makefile
new file mode 100644
index 000000000000..0b338ccc565b
--- /dev/null
+++ b/devel/R-cran-future.apply/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= future.apply
+DISTVERSION= 1.11.2
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= Apply Function to Elements in Parallel using Futures
+WWW= https://cran.r-project.org/web/packages/future.apply/
+
+LICENSE= GPLv2+
+
+CRAN_DEPENDS= R-cran-future>=1.28.0:devel/R-cran-future \
+ R-cran-globals>=0.16.1:devel/R-cran-globals
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>