aboutsummaryrefslogtreecommitdiff
path: root/devel/RStudio/files/patch-src_cpp_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'devel/RStudio/files/patch-src_cpp_CMakeLists.txt')
-rw-r--r--devel/RStudio/files/patch-src_cpp_CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/devel/RStudio/files/patch-src_cpp_CMakeLists.txt b/devel/RStudio/files/patch-src_cpp_CMakeLists.txt
new file mode 100644
index 000000000000..6754f2c1a030
--- /dev/null
+++ b/devel/RStudio/files/patch-src_cpp_CMakeLists.txt
@@ -0,0 +1,18 @@
+--- src/cpp/CMakeLists.txt.orig 2021-05-24 22:22:25 UTC
++++ src/cpp/CMakeLists.txt
+@@ -433,11 +433,11 @@ endif()
+ if(UNIX)
+ set(SOCI_LIBRARY_DIR "${RSTUDIO_TOOLS_SOCI}/build/lib")
+ if(NOT APPLE AND RSTUDIO_USE_SYSTEM_SOCI)
+- set(SOCI_LIBRARY_DIR "/usr/lib")
++ set(SOCI_LIBRARY_DIR "${FREEBSD_LOCALBASE}/lib")
+ endif()
+- find_library(SOCI_CORE_LIB NAMES "libsoci_core.a" "soci_core" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
+- find_library(SOCI_SQLITE_LIB NAMES "libsoci_sqlite3.a" "soci_sqlite3" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
+- find_library(SOCI_POSTGRESQL_LIB NAMES "libsoci_postgresql.a" "soci_postgresql" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
++ find_library(SOCI_CORE_LIB NAMES "libsoci_core.so" "soci_core" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
++ find_library(SOCI_SQLITE_LIB NAMES "libsoci_sqlite3.so" "soci_sqlite3" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
++ find_library(SOCI_POSTGRESQL_LIB NAMES "libsoci_postgresql.so" "soci_postgresql" PATHS "${SOCI_LIBRARY_DIR}" NO_DEFAULT_PATH)
+ find_library(DL_LIB "dl")
+ find_library(SQLITE_LIB "sqlite3")
+ get_filename_component(SQLITE_LIB "${SQLITE_LIB}" REALPATH)