aboutsummaryrefslogtreecommitdiff
path: root/devel/appstream-glib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/appstream-glib/Makefile')
-rw-r--r--devel/appstream-glib/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/appstream-glib/Makefile b/devel/appstream-glib/Makefile
index 9dd7146d2f38..a05fde0dd1e2 100644
--- a/devel/appstream-glib/Makefile
+++ b/devel/appstream-glib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= appstream-glib
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.7
CATEGORIES= devel
MASTER_SITES= http://people.freedesktop.org/~hughsient/appstream-glib/releases/
DIST_SUBDIR= gnome3
@@ -10,23 +10,24 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library to help with AppStream metadata
-LICENSE= LGPL21
+LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc \
gcab:${PORTSDIR}/archivers/gcab
LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libyaml.so:${PORTSDIR}/textproc/libyaml \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= gcab:${PORTSDIR}/archivers/gcab
-USES= gettext gperf gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gperf gmake gnome libarchive libtool pathfix \
+ pkgconfig sqlite tar:xz
USE_GNOME= gdkpixbuf2 glib20 gtk30 intlhack introspection:build \
libxml2:build pango
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_SQLITE= 3
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-xml-catalog=${LOCALBASE}/share/xml/catalog \
@@ -44,10 +45,6 @@ MANPAGES_USE= GNOME=libxslt:build
.include <bsd.port.options.mk>
-.if !exists(/usr/libdata/pkgconfig/libarchive.pc)
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif
-
.if ${OSVERSION} < 1000000 && ${OPSYS} == FreeBSD
post-patch:
${REINPLACE_CMD} -e 's|-Wtype-limits||g' \