aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino-avrdude/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/arduino-avrdude/Makefile')
-rw-r--r--devel/arduino-avrdude/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/arduino-avrdude/Makefile b/devel/arduino-avrdude/Makefile
index 65f665b5ccf6..108b5ffd4324 100644
--- a/devel/arduino-avrdude/Makefile
+++ b/devel/arduino-avrdude/Makefile
@@ -1,12 +1,13 @@
PORTNAME= avrdude
PORTVERSION= 6.3
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= SAVANNAH/avrdude
PKGNAMEPREFIX= arduino-
MAINTAINER= kevans@FreeBSD.org
COMMENT= Program for programming the on-chip memory of Atmel AVR Arduino CPUs
+WWW= https://www.nongnu.org/avrdude/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -14,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libftdi1.so:devel/libftdi1
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
USES= libtool localbase readline
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -25,7 +27,7 @@ CONFIGURE_ARGS+= --disable-shared --disable-static
PLIST_FILES= bin/arduino-avrdude \
etc/arduino-avrdude.conf \
- man/man1/arduino-avrdude.1.gz
+ share/man/man1/arduino-avrdude.1.gz
post-patch:
@${REINPLACE_CMD} -e 's|-lusb-1.0|-lusb|g' ${WRKSRC}/configure