aboutsummaryrefslogtreecommitdiff
path: root/devel/atf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/atf/Makefile')
-rw-r--r--devel/atf/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/devel/atf/Makefile b/devel/atf/Makefile
index 3f98bdc63f29..c12b6874a3d0 100644
--- a/devel/atf/Makefile
+++ b/devel/atf/Makefile
@@ -1,37 +1,32 @@
PORTNAME= atf
PORTVERSION= 0.21
+PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= https://github.com/jmmv/${PORTNAME}/releases/download/${PORTNAME}-${PORTVERSION}/ \
- LOCAL/jmmv
-MAINTAINER= jmmv@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= C, C++ and shell libraries to write ATF-compliant test programs
+WWW= https://github.com/jmmv/atf/
LICENSE= BSD3CLAUSE
+USES= autoreconf libtool pathfix
+USE_CXXSTD= gnu++11
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+GH_TAGNAME= 55c21b2
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-USES= libtool
OPTIONS_DEFINE= DOCS TEST
OPTIONS_DEFAULT=TEST
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-MAKE_FLAGS+= atf_pkgconfigdir=${PREFIX}/libdata/pkgconfig
-.if empty(PORT_OPTIONS:MDOCS)
-MAKE_FLAGS+= doc_DATA=
-.endif
-.if empty(PORT_OPTIONS:MTEST)
-PLIST_SUB+= TEST="@comment "
-.else
-PLIST_SUB+= TEST=
-.endif
+DOCS_MAKE_ARGS_OFF= doc_DATA=
-post-install:
-.if empty(PORT_OPTIONS:MTEST)
+post-install-TEST-off:
@${RM} -r ${STAGEDIR}${PREFIX}/tests
-.endif
.include <bsd.port.mk>