aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf262/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/autoconf262/Makefile')
-rw-r--r--devel/autoconf262/Makefile73
1 files changed, 0 insertions, 73 deletions
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
deleted file mode 100644
index 888fa6bc9901..000000000000
--- a/devel/autoconf262/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# New ports collection makefile for: autoconf
-# Date created: 7 October 1995
-# Whom: torstenb@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= autoconf
-PORTVERSION= 2.57
-PORTREVISION= 0
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= autoconf
-DISTNAME= autoconf-${PORTVERSION}
-
-MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms
-
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- help2man:${PORTSDIR}/misc/help2man
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-
-BUILD_VERSION= 257
-PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= autoconf${BUILD_VERSION}
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5= yes
-USE_REINPLACE= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CONFIG_SHELL=${SH}
-CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION} --without-lispdir
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh \
- missing mkinstalldirs
-
-MAN1_PAGES= autoconf autoheader autom4te autoreconf autoscan \
- autoupdate config.guess config.sub ifnames
-MAN1= ${MAN1_PAGES:S/$/${BUILD_VERSION}.1/g}
-
-.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
-pre-everything::
- @${ECHO} ===========================================================
- @${ECHO} "You have 'USE_AUTOCONF' or 'USE_AUTOCONF_VER' variables"
- @${ECHO} "defined either in environment or in make(1) arguments."
- @${ECHO} "Please undefine them and try again."
- @${ECHO} ===========================================================
- @${FALSE}
-.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
-
-post-patch:
- @(cd ${WRKSRC} && ${REINPLACE_CMD} -E 's,(PACKAGE=autoconf),\1${BUILD_VERSION},' configure)
- @(cd ${WRKSRC}/man && \
- for file in *.[1x]; do \
- ${REINPLACE_CMD} -E 's,([^-]auto)(conf|make|reconf|update|header|scan),\1\2${BUILD_VERSION},g ; \
- s,(config\.guess|config\.sub|ifnames),\1${BUILD_VERSION},g' $$file ; \
- done)
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info && \
- ${MV} autoconf.texi autoconf${BUILD_VERSION}.texi && \
- ${MV} standards.texi standards${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(autoconf)\),\1${BUILD_VERSION}\),g' autoconf${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(autoconf|standards)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in)
-
-post-install:
-.for FILE in ${GENERIC_TOOLS}
- ${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf${BUILD_VERSION}
-.endfor
-
-.include <bsd.port.mk>