aboutsummaryrefslogtreecommitdiff
path: root/devel/avrdude/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/avrdude/Makefile')
-rw-r--r--devel/avrdude/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/devel/avrdude/Makefile b/devel/avrdude/Makefile
index 8c791a1eb029..503de0606985 100644
--- a/devel/avrdude/Makefile
+++ b/devel/avrdude/Makefile
@@ -1,33 +1,31 @@
-# Created by: Brian Dean <bsd@FreeBSD.org>
-
PORTNAME= avrdude
-PORTVERSION= 7.0
-PORTREVISION= 1
+PORTVERSION= 7.3
+DISTVERSIONPREFIX= v
+#PORTREVISION= 0
CATEGORIES= devel
MAINTAINER= joerg@FreeBSD.org
COMMENT= Program for programming the on-chip memory of Atmel AVR CPUs
+WWW= https://www.nongnu.org/avrdude/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
USES= libtool localbase readline cmake
USE_GITHUB= yes
GH_ACCOUNT= avrdudes
GH_PROJECT= avrdude
-GH_TAGNAME= v${PORTVERSION}
OPTIONS_DEFINE= FTDI PARPORT
OPTIONS_DEFAULT= FTDI
FTDI_DESC= libftdi support
FTDI_LIB_DEPENDS= libftdi1.so:devel/libftdi1
PARPORT_DESC= support for parallel-port programmers
-PARPORT_CONFIGURE_ENABLE= parport
+PARPORT_CMAKE_ON= -DHAVE_PARPORT=1
# man page currently not handled by CMake
# https://github.com/avrdudes/avrdude/issues/947
post-install:
- ${GZIP_CMD} < ${WRKSRC}/src/avrdude.1 > ${STAGEDIR}/${MANPREFIX}/man/man1/avrdude.1.gz
+ ${GZIP_CMD} < ${WRKSRC}/src/avrdude.1 > ${STAGEDIR}/${PREFIX}/share/man/man1/avrdude.1.gz
.include <bsd.port.mk>