aboutsummaryrefslogtreecommitdiff
path: root/devel/aws-c-http/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/aws-c-http/Makefile')
-rw-r--r--devel/aws-c-http/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/devel/aws-c-http/Makefile b/devel/aws-c-http/Makefile
index 96daa1509527..3591b1ca3fb4 100644
--- a/devel/aws-c-http/Makefile
+++ b/devel/aws-c-http/Makefile
@@ -1,29 +1,30 @@
-# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
-
PORTNAME= aws-c-http
-PORTVERSION= 0.6.8
DISTVERSIONPREFIX= v
+DISTVERSION= 0.8.1
CATEGORIES= devel
-MAINTAINER= danilo@FreeBSD.org
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= C99 implementation of the HTTP/1.1 and HTTP/2 specifications
+WWW= https://github.com/awslabs/aws-c-http
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libaws-c-common.so:devel/aws-c-common \
- libaws-c-cal.so:security/aws-c-cal \
- libaws-c-io.so:devel/aws-c-io \
+LIB_DEPENDS= libaws-c-cal.so:security/aws-c-cal \
+ libaws-c-common.so:devel/aws-c-common \
libaws-c-compression.so:devel/aws-c-compression \
- libs2n.so:security/s2n
+ libaws-c-io.so:devel/aws-c-io \
+ libs2n.so:security/s2n-tls
-USES= cmake compiler:c11 ssl
+USES= cmake:testing ssl
USE_GITHUB= yes
GH_ACCOUNT= awslabs
-CMAKE_ARGS+= -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=ON \
- -DCMAKE_PREFIX_PATH=${LOCALBASE}
-
USE_LDCONFIG= yes
+CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE}
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_TESTING
+
.include <bsd.port.mk>