aboutsummaryrefslogtreecommitdiff
path: root/devel/capnproto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/capnproto/Makefile')
-rw-r--r--devel/capnproto/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/devel/capnproto/Makefile b/devel/capnproto/Makefile
index 356fb7844577..c2e86eefb40d 100644
--- a/devel/capnproto/Makefile
+++ b/devel/capnproto/Makefile
@@ -1,27 +1,26 @@
-# Created by: Felix Hanley
-
PORTNAME= capnproto
-PORTVERSION= 0.9.0
-DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.2
CATEGORIES= devel
+MASTER_SITES= https://capnproto.org/
+DISTNAME= ${PORTNAME}-c++-${DISTVERSION}
MAINTAINER= felix@userspace.com.au
COMMENT= Serialization/RPC system
+WWW= https://capnproto.org/
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/../LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= autoreconf compiler:c++14-lang cpe gmake libtool ssl
-USE_GITHUB= yes
+USES= cmake:testing compiler:c++14-lang cpe pathfix ssl
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_lib_ssl_OPENSSL_init_ssl=yes
-INSTALL_TARGET= install-strip
-TEST_TARGET= check
+CONFLICTS_INSTALL= capnproto080
+
+CMAKE_TESTING_ON= BUILD_TESTING
-WRKSRC_SUBDIR= c++
+PLIST_SUB= DISTVERSION="${DISTVERSION}"
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_TESTING
.include <bsd.port.mk>