aboutsummaryrefslogtreecommitdiff
path: root/devel/ccache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ccache/Makefile')
-rw-r--r--devel/ccache/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index e4b9a6f3d7fc..aa23e58fd1d8 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -1,19 +1,18 @@
-# Created by: Dominic Marks <d.marks@student.umist.ac.uk>
-
PORTNAME= ccache
PORTVERSION= 3.7.12
-PORTREVISION= 3
+PORTREVISION= 6
CATEGORIES= devel
MASTER_SITES= https://github.com/ccache/ccache/releases/download/v${DISTVERSION}/ \
LOCAL/bdrewery
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Tool to minimize the compile time of C/C++ programs
+WWW= https://ccache.samba.org/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/GPL-3.0.txt
-CONFLICTS_INSTALL?= ccache-static ccache-memcached ccache-memcached-static
+CONFLICTS_INSTALL?= ccache-static ccache-memcached ccache-memcached-static ccache4
GNU_CONFIGURE= yes
@@ -69,7 +68,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ccache ${STAGEDIR}${PREFIX}/bin
# Memcached uses the 3.5 dev branch which requires asciidoc to generate
# ccache.1.
- ${INSTALL_MAN} ${WRKSRC}/doc/ccache.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/ccache.1 ${STAGEDIR}${PREFIX}/share/man/man1
${MKDIR} ${STAGEDIR}${PREFIX}/${CCLINKDIR}/world
${INSTALL_SCRIPT} ${WRKDIR}/world-ccache \
${STAGEDIR}${PREFIX}/${CCLINKDIR}/world/ccache