aboutsummaryrefslogtreecommitdiff
path: root/devel/clanlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/clanlib/Makefile')
-rw-r--r--devel/clanlib/Makefile64
1 files changed, 0 insertions, 64 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
deleted file mode 100644
index 7738a6b95d89..000000000000
--- a/devel/clanlib/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
-
-PORTNAME= clanlib
-PORTVERSION= 2.3.7
-PORTREVISION= 19
-PORTEPOCH= 1
-CATEGORIES= devel
-MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
-DISTNAME= ClanLib-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Cross-platform game SDK
-
-LICENSE= ZLIB
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN_i386= typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
-BROKEN_powerpc= typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
-
-DEPRECATED= Upstream no longer maintained
-EXPIRATION_DATE= 2021-10-31
-
-LIB_DEPENDS= libpng.so:graphics/png \
- libmikmod.so:audio/libmikmod \
- libvorbis.so:audio/libvorbis \
- libogg.so:audio/libogg \
- libfontconfig.so:x11-fonts/fontconfig \
- libpcre.so:devel/pcre \
- libfreetype.so:print/freetype2
-
-USES= compiler:c++11-lib cpe gl gmake jpeg libtool localbase:ldflags \
- pathfix pkgconfig sqlite tar:tgz xorg
-USE_XORG= x11 xrender
-USE_LDCONFIG= yes
-USE_GL= gl
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-docs \
- --enable-clanDisplay \
- --enable-clanGL \
- --enable-clanGL1 \
- --enable-clanSound \
- --enable-clanDatabase \
- --enable-clanSqlite \
- --enable-clanRegExp \
- --enable-clanNetwork \
- --enable-clanGUI \
- --enable-clanCSSLayout \
- --enable-clanSWRender \
- --enable-clanMikMod \
- --enable-clanVorbis \
- --enable-getaddr
-
-INSTALL_TARGET= install-strip
-PLIST_SUB+= VER=${PORTVERSION:R} \
- SHORT_VER=${PORTVERSION:R:R}${PORTVERSION:R:E}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|LIBS="-lsqlite3 -ldl"|LIBS="-lsqlite3"|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '114 s|/proc/self/exe|/proc/curproc/file|g' \
- ${WRKSRC}/Sources/Core/System/Unix/init_linux.cpp
-
-.include <bsd.port.mk>