aboutsummaryrefslogtreecommitdiff
path: root/devel/concurrencpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/concurrencpp/Makefile')
-rw-r--r--devel/concurrencpp/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/concurrencpp/Makefile b/devel/concurrencpp/Makefile
index c137acff6364..abef06fe736c 100644
--- a/devel/concurrencpp/Makefile
+++ b/devel/concurrencpp/Makefile
@@ -1,23 +1,29 @@
PORTNAME= concurrencpp
DISTVERSIONPREFIX= v.
-DISTVERSION= 0.1.3
+DISTVERSION= 0.1.7
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ concurrency library: tasks, executors, timers, C++20 coroutines
+WWW= https://github.com/David-Haim/concurrencpp
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_FreeBSD_12= fatal error: 'semaphore' file not found (missing C++ include <semaphore>)
-
-USES= cmake compiler:c++17-lang # should be compiler:c++20-lang
+USES= cmake compiler:c++20-lang
USE_GITHUB= yes
GH_ACCOUNT= David-Haim
CMAKE_ON= BUILD_SHARED_LIBS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64le || ${ARCH} == powerpc64 || ${ARCH} == powerpc
+CXX= clang++${LLVM_VERSION}
+USES+= llvm:min=16
+.endif
+
do-test: # same as recommended in https://github.com/David-Haim/concurrencpp#building-installing-and-testing
@cd ${WRKSRC} && \
${CMAKE_BIN} -S test -B build/test && \