aboutsummaryrefslogtreecommitdiff
path: root/devel/csmith/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/csmith/Makefile')
-rw-r--r--devel/csmith/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
index 4c0cea82f0c3..5cda8e795498 100644
--- a/devel/csmith/Makefile
+++ b/devel/csmith/Makefile
@@ -5,21 +5,30 @@ MASTER_SITES= http://embed.cs.utah.edu/csmith/
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates random C programs that conform to the C99 standard
+WWW= https://embed.cs.utah.edu/csmith/
LICENSE= BSD2CLAUSE
+USES= gmake libtool localbase perl5 shebangfix
+USE_CXXSTD= c++11
+USE_LDCONFIG= yes
+USE_PERL5= run
+
+SHEBANG_FILES= scripts/compiler_test.pl scripts/launchn.pl
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR}
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+
INSTALL_TARGET= install-strip
-USES= gmake libtool perl5 shebangfix
-USE_PERL5= run
-SHEBANG_FILES= scripts/compiler_test.pl scripts/launchn.pl
-USE_LDCONFIG= yes
+
+PLIST_SUB= PKGNAME="${PKGNAME}"
OPTIONS_DEFINE= DOCS
-PLIST_SUB= PKGNAME="${PKGNAME}"
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CPPFLAGS+= -Wno-error=enum-constexpr-conversion
+.endif
.include <bsd.port.mk>