aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf-editor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dconf-editor/Makefile')
-rw-r--r--devel/dconf-editor/Makefile32
1 files changed, 20 insertions, 12 deletions
diff --git a/devel/dconf-editor/Makefile b/devel/dconf-editor/Makefile
index e182682b4915..df919913d6c9 100644
--- a/devel/dconf-editor/Makefile
+++ b/devel/dconf-editor/Makefile
@@ -1,20 +1,28 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/dconf-editor/Makefile 19571 2014-04-25 18:12:46Z kwm $
-PORTNAME= dconf
-PORTREVISION= 0
-PKGNAMESUFFIX= -editor
+PORTNAME= dconf-editor
+PORTVERSION= 3.16.1
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
-COMMENT= configuration editor for dconf
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Configuration database editor for GNOME
-DCONF_SLAVE= editor
+BUILD_DEPENDS= dconf>=0.23.2:${PORTSDIR}/devel/dconf \
+ vala>=0.18.1:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libdconf.so:${PORTSDIR}/devel/dconf
-MASTERDIR= ${.CURDIR}/../dconf
+PORTSCOUT= limitw:1,even
-PLIST= ${.CURDIR}/pkg-plist
+USES= gettext gmake pathfix pkgconfig tar:xz
+USE_GNOME= intltool gtk30 libxml2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALLS_ICONS= yes
+GLIB_SCHEMAS= ca.desrt.dconf-editor.gschema.xml
-BUILD_WRKSRC= ${WRKSRC}/editor
-INSTALL_WRKSRC= ${WRKSRC}/editor
-
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>