aboutsummaryrefslogtreecommitdiff
path: root/devel/dee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dee/Makefile')
-rw-r--r--devel/dee/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/devel/dee/Makefile b/devel/dee/Makefile
index 96bda8783c4f..1ec8fbaf528a 100644
--- a/devel/dee/Makefile
+++ b/devel/dee/Makefile
@@ -1,35 +1,33 @@
-# Created by: Olivier Duchateau
-
PORTNAME= dee
PORTVERSION= 1.2.7
-PORTREVISION= 20
+PORTREVISION= 25
CATEGORIES= devel
MASTER_SITES= https://launchpadlibrarian.net/151383425/ \
https://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Model to synchronize multiple instances over DBus
+WWW= https://launchpad.net/dee
LICENSE= GPLv3
EXTRA_PATCHES= ${FILESDIR}/dee-1.2.7-deprecated-g_type_class_add_private.patch:-p1 \
${FILESDIR}/vapi-skip-properties.patch:-p1
-BUILD_DEPENDS= vapigen:lang/vala
LIB_DEPENDS= libicutu.so:devel/icu
USES= compiler:c11 gmake gnome libtool localbase pathfix pkgconfig \
- python:3.5+
-GNU_CONFIGURE= yes
+ python vala:build
USE_GNOME= glib20 introspection:build pygobject3
-USE_LDCONFIG= yes
-
-CONFIGURE_ARGS= --disable-gtk-doc-html \
- --disable-tests \
- --disable-gcov \
- --enable-introspection=yes \
- --without-html-dir
+CONFIGURE_ARGS= --disable-gcov \
+ --disable-gtk-doc-html \
+ --disable-tests \
+ --enable-introspection=yes \
+ --without-html-dir
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKE_ARGS= PYTHON="${PYTHON_CMD}"
+USE_LDCONFIG= yes
.include <bsd.port.mk>