aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-hat/Makefile')
-rw-r--r--devel/hs-hat/Makefile104
1 files changed, 0 insertions, 104 deletions
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
deleted file mode 100644
index 9862aee52238..000000000000
--- a/devel/hs-hat/Makefile
+++ /dev/null
@@ -1,104 +0,0 @@
-# New ports collection makefile for: nhc98
-# Date created: 04 October 2001
-# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
-#
-# $FreeBSD$
-
-PORTNAME= nhc98
-PORTVERSION= 1.12
-CATEGORIES= lang
-MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
-DISTNAME= ${PORTNAME}src-${PORTVERSION}
-DIST_SUBDIR= nhc98
-
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= patch-1.12-ranlib \
- patch-1.12-hmake-config \
- patch-1.12-getEnv
-
-MAINTAINER= obraun@informatik.unibw-muenchen.de
-
-.if defined(WITH_TRACER)
-RUN_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk
-BUILD_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/javac:${PORTSDIR}/java/jdk
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-.endif
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST= ${WRKSRC}/pkg-plist
-
-.if !defined(WITH_TRACER)
-ALL_TARGET= basic
-PLIST_SUB+= TRACER="@comment "
-.else
-PLIST_SUB+= TRACER=""
-MAKE_ENV+= PATH=${PREFIX}/jdk1.1.8/bin:$$PATH
-.endif
-
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-
-.if ${OSVERSION} >= 500000
-CONFIGURE_ARGS+= --buildwith=ghc
-.endif
-
-.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${PREFIX}/share/doc/nhc98 +docs
-.endif
-
-MAN1= harch.1 hmake.1 hp2graph.1 nhc98.1 \
- hat-detect.1 hat-observe.1 hat-stack.1 hat-trail.1
-
-pre-fetch:
-.if !defined(WITH_TRACER)
- @${ECHO} ""
- @${ECHO} " To build nhc98 with the tracer (requires JAVA)"
- @${ECHO} " define WITH_TRACER"
- @${ECHO} ""
-.else
- @${ECHO} ""
- @${ECHO} " Building nhc98 with the tracer (requires JAVA)"
- @${ECHO} ""
-.endif
-
-post-patch:
- @${PERL} -pi.orig -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile.inc
-
-# We need this to ensure that the libs will be installed into
-# ${PREFIX}/lib/nhc98. Otherwise the libs will be installed
-# into the build directory. The configure option won't work in the
-# ports system.
-pre-install:
- ${RM} -f ${WRKSRC}/include/*.orig
- ${SED} -e "s#LIBDIR=.*##" \
- < ${WRKSRC}/targets/ix86-FreeBSD/config.cache \
- > ${WRKSRC}/targets/ix86-FreeBSD/config.cache.fix1
- ${ECHO} "LIBDIR=${PREFIX}/lib/nhc98" \
- >> ${WRKSRC}/targets/ix86-FreeBSD/config.cache.fix1
- ${RM} ${WRKSRC}/targets/ix86-FreeBSD/config.cache
- ${MV} ${WRKSRC}/targets/ix86-FreeBSD/config.cache.fix1 \
- ${WRKSRC}/targets/ix86-FreeBSD/config.cache
-
-post-install:
- ${SED} -e "s#/usr/doc/nhc98#${PREFIX}/share/doc/nhc98#" \
- < ${WRKSRC}/man/nhc98.1 > ${WRKSRC}/man/nhc98.1.fix
- ${INSTALL_MAN} ${WRKSRC}/man/nhc98.1.fix ${PREFIX}/man/man1/nhc98.1
- ${RM} ${WRKSRC}/man/nhc98.1.fix
-.if !defined(NOPORTDOCS)
-.for ending in aux log
- ${RM} ${PREFIX}/share/doc/nhc98/hat/tutorial1.${ending}
-.endfor
-.for ending in aux log out toc
- ${RM} ${PREFIX}/share/doc/nhc98/hat/hatuser.${ending}
-.endfor
-.for directory in . bugs examples hat hmake implementation-notes libs
- ${RM} -r ${PREFIX}/share/doc/nhc98/${directory}/CVS
-.endfor
-.endif
-
-.include <bsd.port.post.mk>