aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hlint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-hlint/Makefile')
-rw-r--r--devel/hs-hlint/Makefile81
1 files changed, 42 insertions, 39 deletions
diff --git a/devel/hs-hlint/Makefile b/devel/hs-hlint/Makefile
index a506a4ed6030..1e95ab5eddd3 100644
--- a/devel/hs-hlint/Makefile
+++ b/devel/hs-hlint/Makefile
@@ -1,6 +1,6 @@
PORTNAME= hlint
PORTVERSION= 3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,22 +11,23 @@ LICENSE= BSD3CLAUSE
USES= cabal
-USE_CABAL= OneTuple-0.3.1_2 \
+USE_CABAL= OneTuple-0.3.1_3 \
QuickCheck-2.14.2 \
StateVar-1.2.2 \
- aeson-2.0.3.0 \
+ aeson-2.1.1.0 \
ansi-terminal-0.11.3 \
- assoc-1.0.2_2 \
- attoparsec-0.14.4_1 \
- base-compat-0.12.1 \
- base-compat-batteries-0.12.1_2 \
- base-orphans-0.8.6 \
- bifunctors-5.5.12 \
+ assoc-1.0.2_3 \
+ attoparsec-0.14.4_2 \
+ base-compat-0.12.2 \
+ base-compat-batteries-0.12.2 \
+ base-orphans-0.8.7 \
+ bifunctors-5.5.13 \
+ bitvec-1.1.3.0 \
clock-0.8.3 \
cmdargs-0.10.21 \
colour-2.3.6 \
comonad-5.0.8_1 \
- conduit-1.3.4.2 \
+ conduit-1.3.4.3_1 \
contravariant-1.5.5 \
cpphs-1.20.9.1_1 \
data-default-0.7.1.1 \
@@ -34,47 +35,49 @@ USE_CABAL= OneTuple-0.3.1_2 \
data-default-instances-containers-0.0.1 \
data-default-instances-dlist-0.0.1 \
data-default-instances-old-locale-0.0.1 \
- data-fix-0.3.2_2 \
+ data-fix-0.3.2_3 \
distributive-0.6.2.1_1 \
dlist-1.0 \
- extra-1.7.10 \
+ extra-1.7.12 \
file-embed-0.0.15.0 \
- filepattern-0.1.2 \
- ghc-lib-parser-ex-9.2.0.3 \
- hashable-1.4.0.2 \
+ filepattern-0.1.3 \
+ generically-0.1 \
+ ghc-lib-parser-ex-9.2.0.4 \
+ hashable-1.4.1.0 \
hscolour-1.24.4 \
- indexed-traversable-0.1.2_1 \
- indexed-traversable-instances-0.1.1 \
- integer-logarithms-1.0.3.1_2 \
- libyaml-0.1.2 \
+ indexed-traversable-0.1.2_2 \
+ indexed-traversable-instances-0.1.1.1 \
+ integer-logarithms-1.0.3.1_3 \
+ libyaml-0.1.2_1 \
mono-traversable-1.0.15.3 \
old-locale-1.0.0.7_2 \
- polyparse-1.13_4 \
- primitive-0.7.3.0 \
+ polyparse-1.13_5 \
+ primitive-0.7.4.0 \
random-1.2.1.1 \
refact-0.3.0.2 \
- resourcet-1.2.4.3_1 \
- scientific-0.3.7.0_2 \
- semialign-1.2.0.1_1 \
+ resourcet-1.3.0 \
+ scientific-0.3.7.0_3 \
+ semialign-1.2.0.1_3 \
semigroupoids-5.3.7 \
- split-0.2.3.4_2 \
- splitmix-0.1.0.4 \
+ split-0.2.3.5 \
+ splitmix-0.1.0.4_1 \
strict-0.4.0.1_4 \
- syb-0.7.2.1 \
- tagged-0.8.6.1_2 \
- text-short-0.1.5 \
- th-abstraction-0.4.3.0 \
- these-1.1.1.1_5 \
- time-compat-1.9.6.1_3 \
- transformers-compat-0.7.1_1 \
+ syb-0.7.2.2 \
+ tagged-0.8.6.1_3 \
+ text-short-0.1.5_1 \
+ th-abstraction-0.4.5.0 \
+ these-1.1.1.1_6 \
+ time-compat-1.9.6.1_4 \
+ transformers-compat-0.7.2 \
uniplate-1.6.13_1 \
unliftio-core-0.2.0.1_2 \
- unordered-containers-0.2.19.1 \
+ unordered-containers-0.2.19.1_1 \
utf8-string-1.0.2 \
- uuid-types-1.0.5_2 \
- vector-0.12.3.1_1 \
- vector-algorithms-0.8.0.4_1 \
- witherable-0.4.2_2 \
- yaml-0.11.8.0
+ uuid-types-1.0.5_3 \
+ vector-0.13.0.0_1 \
+ vector-algorithms-0.9.0.1_1 \
+ vector-stream-0.1.0.0_1 \
+ witherable-0.4.2_3 \
+ yaml-0.11.8.0_2
.include <bsd.port.mk>