aboutsummaryrefslogtreecommitdiff
path: root/devel/ice/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ice/Makefile')
-rw-r--r--devel/ice/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 9e6b243bfef0..bd6dee549a6a 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Ice
PORTVERSION= 3.5.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://download.zeroc.com/Ice/3.5/
@@ -12,8 +12,16 @@ COMMENT= Modern alternative to object middleware such as CORBA/COM/DCOM/COM+
LICENSE= GPLv2
+SLAVE_PORT?= no
+
+.if ${SLAVE_PORT} == "no"
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libmcpp.so:${PORTSDIR}/devel/mcpp
+.else
+LIB_VRS= ${PORTVERSION:R:S|.||g}
+LIB_DEPENDS+= libIce.so.${LIB_VRS}:${PORTSDIR}/devel/ice
+PLIST_SUB+= LIB_VERSION="${PORTVERSION}" LIB_VRS="${LIB_VRS}"
+.endif
OPTIONS_DEFINE?= DEBUG DEMOS DOCS TESTS
OPTIONS_DEFAULT?= DEMOS TESTS
@@ -22,11 +30,12 @@ DEMOS_DESC?= Build demos
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MTESTS}
-USE_PYTHON_BUILD= yes
+USES+= iconv gmake
+
+.if ${PORT_OPTIONS:MTESTS} && ${SLAVE_PORT} == "no"
+USES+= python:build
.endif
-USES= iconv gmake
USE_BDB= yes
WANT_BDB_VER= 5
INVALID_BDB_VER= 40 41 42 43 44 46 47 48 6