aboutsummaryrefslogtreecommitdiff
path: root/devel/kio-extras/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kio-extras/Makefile')
-rw-r--r--devel/kio-extras/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/devel/kio-extras/Makefile b/devel/kio-extras/Makefile
index 850bee70aebb..4354e3fe343e 100644
--- a/devel/kio-extras/Makefile
+++ b/devel/kio-extras/Makefile
@@ -4,10 +4,11 @@ CATEGORIES= devel kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 library to increase the functionality of KIO
+WWW= https://projects.kde.org/projects/kde/workspace/kio-extras
LIB_DEPENDS= libtag.so:audio/taglib \
libImath.so:math/Imath \
- libkdsoap.so:www/kdsoap
+ libkdsoap.so:www/kdsoap@qt5
USES= cmake compiler:c++11-lib gettext gperf kde:5 \
pkgconfig qt:5 shared-mime-info shebangfix tar:xz xorg
@@ -15,26 +16,32 @@ USE_KDE= activities archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons dnssd doctools \
emoticons guiaddons i18n iconthemes init itemmodels itemviews \
jobwidgets js kdelibs4support khtml kio notifications parts \
- pty service solid sonnet syntaxhighlighting textwidgets unitconversion \
+ phonon pty service solid sonnet syntaxhighlighting textwidgets unitconversion \
widgetsaddons windowsystem xmlgui \
- ecm_build
-USE_QT= concurrent core dbus declarative gui location network phonon4 printsupport \
+ ecm:build
+USE_QT= concurrent core dbus declarative gui location network printsupport \
sql svg testlib webchannel widgets xml \
- buildtools_build qmake_build
-USE_XORG= xcursor
+ buildtools:build qmake:build
+USE_XORG= x11 xcursor
SHEBANG_FILES= info/kde-info2html
# CVE-2018-19120
CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidget
-OPTIONS_DEFINE= SAMBA MTP EXR EXIV SLP SSH TAGLIB DOCS
-OPTIONS_DEFAULT=SAMBA MTP EXR EXIV SLP SSH TAGLIB
+OPTIONS_DEFINE= SAMBA AFC MTP EXR EXIV SLP SSH TAGLIB DOCS
+OPTIONS_DEFAULT= SAMBA AFC MTP EXR EXIV SLP SSH TAGLIB
OPTIONS_SUB= yes
SAMBA_DESC= Needed to build the SMB kioslave
SAMBA_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Samba
SAMBA_USES= samba:lib
+AFC_DESC= Needed to build AFC (Apple File Conduit) kioslave
+AFC_LIB_DEPENDS= libimobiledevice-1.0.so:comms/libimobiledevice \
+ libplist-2.0.so:devel/libplist
+AFC_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_IMobileDevice \
+ CMAKE_DISABLE_FIND_PACKAGE_PList
+
MTP_DESC= Needed to build the MTP kioslave
MTP_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Mtp
MTP_LIB_DEPENDS= libmtp.so:multimedia/libmtp
@@ -44,8 +51,8 @@ EXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
EXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
EXIV_DESC= Provides support for automatic rotation of JPEGs in the thumbnail kioslave
-EXIV_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Exiv2
-EXIV_LIB_DEPENDS= libexiv2.so:graphics/exiv2
+EXIV_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_KF5kExiv2
+EXIV_USE= KDE=libkexiv2
SLP_DESC= Provides SLP support in the network:/ kioslave
SLP_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_SLP