aboutsummaryrefslogtreecommitdiff
path: root/devel/libsigrok/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libsigrok/Makefile')
-rw-r--r--devel/libsigrok/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/libsigrok/Makefile b/devel/libsigrok/Makefile
index 78084adea97a..60b06086f278 100644
--- a/devel/libsigrok/Makefile
+++ b/devel/libsigrok/Makefile
@@ -22,7 +22,11 @@ MAKE_JOBS_UNSAFE= yes
LDFLAGS+= -L/usr/lib -lusb
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
# Workaround for libusb not knowing LIBUSB_CLASS_APPLICATION
+.if (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100029) || (${OSVERSION} < 1000715)
CFLAGS+= -DLIBUSB_CLASS_APPLICATION=0xfe
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>