aboutsummaryrefslogtreecommitdiff
path: root/devel/libslang2-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libslang2-devel/Makefile')
-rw-r--r--devel/libslang2-devel/Makefile62
1 files changed, 0 insertions, 62 deletions
diff --git a/devel/libslang2-devel/Makefile b/devel/libslang2-devel/Makefile
deleted file mode 100644
index 389ff4b35a0d..000000000000
--- a/devel/libslang2-devel/Makefile
+++ /dev/null
@@ -1,62 +0,0 @@
-# New ports collection makefile for: libslang2
-# Date created: 2005-05-16
-# Whom: Renato Botelho <freebsd@galle.com.br>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libslang2
-PORTVERSION= 2.0.7
-CATEGORIES= devel
-MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/v2.0/ \
- ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v2.0/ \
- ftp://ftp.ntua.gr/pub/lang/slang/slang/v2.0/ \
- ftp://ftp.plig.org/pub/slang/v2.0/
-DISTNAME= slang-${PORTVERSION}
-
-MAINTAINER= garga@FreeBSD.org
-COMMENT= Routines for rapid alpha-numeric terminal applications development
-
-USE_BZIP2= yes
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-CONFLICTS= libslang-1.*
-
-ALL_TARGET= all elf
-INSTALL_TARGET= install install-elf
-
-MAN1= slsh.1
-DOCSDIR= ${PREFIX}/share/doc/slang
-DATADIR= ${PREFIX}/share/slsh
-
-OPTIONS= PCRE "Include pcre support" on \
- PNG "Include png support" on
-
-PORTDOCS= *
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_PCRE)
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-PLIST_SUB+= PCRE=""
-.else
-CONFIGURE_ARGS+= --without-pcre
-PLIST_SUB+= PCRE="@comment "
-.endif
-
-.if !defined(WITHOUT_PNG)
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-PLIST_SUB+= PNG=""
-.else
-CONFIGURE_ARGS+= --without-png
-PLIST_SUB+= PNG="@comment "
-.endif
-
-post-patch:
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's, install_docs,,g' ${WRKSRC}/src/Makefile.in
-.endif
-
-.include <bsd.port.post.mk>