aboutsummaryrefslogtreecommitdiff
path: root/devel/py-azure-synapse-managedprivateendpoints/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-azure-synapse-managedprivateendpoints/Makefile')
-rw-r--r--devel/py-azure-synapse-managedprivateendpoints/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/py-azure-synapse-managedprivateendpoints/Makefile b/devel/py-azure-synapse-managedprivateendpoints/Makefile
new file mode 100644
index 000000000000..1ca0b24bd823
--- /dev/null
+++ b/devel/py-azure-synapse-managedprivateendpoints/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= azure-synapse-managedprivateendpoints
+DISTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Microsoft Azure Synapse Managed Private Endpoints Client Library for Python
+WWW= https://pypi.org/project/azure-synapse-managedprivateendpoints/
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msrest>=0.5.0:net-mgmt/py-msrest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-common>=1.1:www/py-azure-common@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-core>=1.6.0<2.0.0:devel/py-azure-core@${PY_FLAVOR}
+
+USES= azurepy python zip
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>