aboutsummaryrefslogtreecommitdiff
path: root/devel/py-frozendict/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-frozendict/Makefile')
-rw-r--r--devel/py-frozendict/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/devel/py-frozendict/Makefile b/devel/py-frozendict/Makefile
index 8b8a6e7941ed..7e19b820c479 100644
--- a/devel/py-frozendict/Makefile
+++ b/devel/py-frozendict/Makefile
@@ -1,20 +1,27 @@
-# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
-
PORTNAME= frozendict
-PORTVERSION= 2.0.3
+PORTVERSION= 2.3.10
+PORTREVISION= 1
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI \
+ https://github.com/Marco-Sulla/python-frozendict/releases/download/v${PORTVERSSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Immutable dictionary implementation for Python
+WWW= https://github.com/Marco-Sulla/python-frozendict
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+MAKE_ARGS= custom_arg=c
-NO_ARCH= yes
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>