aboutsummaryrefslogtreecommitdiff
path: root/devel/py-immutables/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-immutables/Makefile')
-rw-r--r--devel/py-immutables/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/devel/py-immutables/Makefile b/devel/py-immutables/Makefile
index 49483ca47df8..f004ad8be69d 100644
--- a/devel/py-immutables/Makefile
+++ b/devel/py-immutables/Makefile
@@ -1,21 +1,24 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
PORTNAME= immutables
-PORTVERSION= 0.15
+PORTVERSION= 0.20
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Immutable collections
+WWW= https://github.com/MagicStack/immutables
+
+LICENSE= APACHE20 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
-LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-USES= python:3.5+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/immutables/_map*.so
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>