aboutsummaryrefslogtreecommitdiff
path: root/devel/py-isort/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-isort/Makefile')
-rw-r--r--devel/py-isort/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/py-isort/Makefile b/devel/py-isort/Makefile
index 23be857f2438..458e53948db7 100644
--- a/devel/py-isort/Makefile
+++ b/devel/py-isort/Makefile
@@ -1,23 +1,27 @@
PORTNAME= isort
-PORTVERSION= 5.9.2
+PORTVERSION= 5.13.2
+PORTREVISION= 1
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python utility/library to sort Python imports
+WWW= https://github.com/PyCQA/isort
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
OPTIONS_DEFINE= COLORS
COLORS_DESC= Color output support
-COLORS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0.4.3<0.5.0:devel/py-colorama@${PY_FLAVOR}
+COLORS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0.4.6:devel/py-colorama@${PY_FLAVOR}
.include <bsd.port.mk>