aboutsummaryrefslogtreecommitdiff
path: root/devel/py-jupyter-core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-jupyter-core/Makefile')
-rw-r--r--devel/py-jupyter-core/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/devel/py-jupyter-core/Makefile b/devel/py-jupyter-core/Makefile
index e4a01dcd6edd..70317f246728 100644
--- a/devel/py-jupyter-core/Makefile
+++ b/devel/py-jupyter-core/Makefile
@@ -1,27 +1,32 @@
PORTNAME= jupyter-core
-PORTVERSION= 4.7.1
+PORTVERSION= 5.7.2
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI \
+ https://github.com/jupyter/jupyter_core/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= jupyter_core-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Jupyter core package
+WWW= https://jupyter.org/ \
+ https://github.com/jupyter/jupyter_core
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING.md
+LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.4:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}platformdirs>=2.5:devel/py-platformdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=5.3:devel/py-traitlets@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipykernel>=0:devel/py-ipykernel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pre-commit>=0:devel/py-pre-commit@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-timeout>=0:devel/py-pytest-timeout@${PY_FLAVOR}
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+SHEBANG_FILES= jupyter_core/troubleshoot.py
.include <bsd.port.mk>