aboutsummaryrefslogtreecommitdiff
path: root/devel/py-jupyterlab-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-jupyterlab-server/Makefile')
-rw-r--r--devel/py-jupyterlab-server/Makefile43
1 files changed, 28 insertions, 15 deletions
diff --git a/devel/py-jupyterlab-server/Makefile b/devel/py-jupyterlab-server/Makefile
index 6fee129a48a2..5c083c5a67d7 100644
--- a/devel/py-jupyterlab-server/Makefile
+++ b/devel/py-jupyterlab-server/Makefile
@@ -1,30 +1,43 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
PORTNAME= jupyterlab-server
-PORTVERSION= 2.6.1
+PORTVERSION= 2.26.0
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI \
+ https://github.com/jupyterlab/jupyterlab_server/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= jupyterlab_server-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= JupyterLab Server
+WWW= https://jupyterlab-server.readthedocs.io/en/stable/ \
+ https://github.com/jupyterlab/jupyterlab_server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.4<2:devel/py-jupyter-server@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=0:devel/py-babel@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.10:devel/py-Jinja2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}json5>=0:devel/py-json5@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.1:devel/py-jsonschema@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.4<2:devel/py-jupyter-server@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.7:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.10:devel/py-babel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.3:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}json5>=0.9.0:devel/py-json5@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.18.0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.21<3:devel/py-jupyter-server@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.31:www/py-requests@${PY_FLAVOR}
-USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USES= python
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-.include <bsd.port.mk>
+OPTIONS_DEFINE= OPENAPI
+OPENAPI_DESC= OpenAPI support
+
+OPENAPI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openapi-core>=0.18.0<0.19:devel/py-openapi-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0:devel/py-ruamel.yaml@${PY_FLAVOR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4.8.3:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>